Call TIP <Environment>

Piccolo
2014-03-11
2015-04-10
  • Piccolo
    Piccolo
    2014-03-11

    I am creating a Language Call Tip (API)

    My function look like this /copy,Fname1,Ext1,--,Fname2,Ext2,--
    so my startFunc="," is a comma thus when I enter the second , comma in the function the Call Tip goes away.
    How can I handle this? I know I can use a ( as a start function and replace it after the function is written. but I don't like that.
    Here is my code.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    <Environment ignoreCase="yes" startFunc="," stopFunc="," paramSeparator="," terminal="!" additionalWordChar="*/"/>
    <KeyWord name="/copy" func="yes">
    <Overload retVal="char" descr="Copies a file.">
    <Param name="Fname1,Ext1,--,Fname2,Ext2,--"/>
    </Overload>
    </KeyWord>
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

     
    Last edit: Piccolo 2014-03-11
  • Piccolo
    Piccolo
    2014-03-17

    No answer yet? do i have the only language with "," comma separators?
    Two more function examples. ESEL and FLST

    ESEL,S,REAL,,227
    FLST,5,2,2,ORDE,2

     
  • dail8859
    dail8859
    2014-03-17

    Most languages use commas as separators. My guess is that it is getting confused since starting and stopping and also separating the parameters for the function with the same character is ambiguous. It can start the function but when the second comma is entered...how would it determine if its for the next param or ending the function? Others more familiar may be able to help more.

     
    Last edit: dail8859 2014-03-17
  • Piccolo
    Piccolo
    2014-04-07

    Thanks for the comment,

    the stop function does not have to be a comma , it doesn't matter what i define as a stop function or separator the fact that I enter a second comma make the Cal tip disappear, i would like it to stay there until i completed the function.

    <Environment ignoreCase="yes" startFunc="," stopFunc="!" paramSeparator="!" terminal="!" additionalWordChar="*/"/>  
            <KeyWord name="/copy" func="yes" >
                <Overload retVal="char" descr="Copies a file." >
                    <Param name="Fname1,Ext1,--,Fname2,Ext2,--" />
                    </Overload>
            </KeyWord>
    
     
    Last edit: Piccolo 2014-04-07
  • Piccolo
    Piccolo
    2014-11-17

    Anyone with a solution yet,

     
  • Loreia2
    Loreia2
    2014-11-19

    Hi Piccolo,

    this is a highly specialized question. You best option would be to check the source code directly. I would do it myself if I had time, unfortunately that is not the case these days.

    Regards,
    Loreia

     
    Last edit: Loreia2 2014-11-19
  • Piccolo
    Piccolo
    2015-03-26

    Thanks, I am not on the level to find anything in the source code.

    Is there anybody that has tried this?

     
  • JimD
    JimD
    2015-04-10

    Have you tried this:

    <Param name="Fname1"/>
    <Param name="Ext1"/>
    <Param name=.../>
    
     
  • Piccolo
    Piccolo
    2015-04-10

    Thanks for the Tip, but unfortunately that did not work.

    The problem is that the Programming language uses the same start function as the separator.

    /copy,Fname1,Ext1,--,Fname2,Ext2,-- (where /COPY is the command and the rest is the syntext)
    ASK, Par, Query, DVAL (Where ASK is the command)

    So I have a command and then my syntext separated by commas as son as notepad see the second comma it think it is a new command that it does not know and it stop displaying the tool tip for the original command.

    I need a way to tel notepad that it should keep the tool tip there until it see the terminal character that must be a space.