After saving changes text appears as one line

veegertx
2012-10-24
2012-11-13
  • veegertx

    veegertx - 2012-10-24

    I edit a file with Notepad ++ and save but when I right click on that file in Windows explorer and choose edit which by default uses Windows notepad the text appears as one line. This started occuring with last couple versions. I am using 6.2 right now.

    Example a .reg file
    Should look like this

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell
    

    but is appearing in regular notepad like this

    Windows Registry Editor Version 5.00[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore
    

    I know reg files are unicode but I have plain text files where it occasionally does same thing

     
  • fb16

    fb16 - 2012-10-25

    Hi,

    What do you read as "Format" and "Encoding" in: "Settings > Preferences > New Document/Default Directory > New Document"?

    What's the Ending of Line with NPP++: "View > Show Symbol > Show End of Line".

    Try resaving with the "Windows" format and then opening with the regular Windows Notepad. Hope it works.

    Best regards
    fb16

     
  • veegertx

    veegertx - 2012-10-25

    New Doc = Windows
    Format = Ansi
    Show end of line is CRLF

    So those should be normal.

     
  • fb16

    fb16 - 2012-10-25

    Hi,

    yes, those should be normal.

    Version of your Win OS?
    Version of your NPP++?

    Try copying and pasting your reg lines into Wordpad ("%ProgramFiles%\Windows NT\Accessories\wordpad.exe"), and then pasting the lines back on the regular notepad. Does it work?

    Best regards
    fb16

     
  • fb16

    fb16 - 2012-10-25

    Ok, I re-read, your NPP++ version is 6.2… what is your OS?
    Thanks
    fb16

     
  • fb16

    fb16 - 2012-10-25

    Hi,

    I made a quick test. I'm on Win7 Pro 64bit. My preferences in "Settings > Preferences > New Document/Default Directory > New Document" are:
    New Doc = Unix
    Format = UTF-8 without BOM ("Apply to opened ANSI files" currently checked)

    1) Launched "C:\Windows\regedit.exe"
    2) Exported with "File > Export" as "test.reg"
    3) Right clicked over "test.reg" and chosen "Edit with Notepad++"
    4) Edited the file, and saved it
    5) Right clicked over "test.reg" again, and chosen "Open with > Notepad" (this time the regular Windows Notepad)

    No issues with lines, here.

    Best regards
    fb16

     
  • veegertx

    veegertx - 2012-10-25

    Not sure I should do that
    The format of Windows and Unix text files differs slightly. In Windows, lines end with both the line feed and carriage return ASCII characters, but Unix uses only a line feed.

    I wish I had saved one of those files that ended up wrong but I done a restore image with acronis and fresh install of NPP and today it hasn't happened yet.