SourceForge has been redesigned. Learn more.
Close

Scintilla build failed

CFrank
2013-02-02
2013-03-23
  • CFrank

    CFrank - 2013-02-02

    Hi,
    as the subject suggests I tried to build npp and scintilla from the sources
    using windows 7 64bit, windows sdk 7.1 and visual studion 2010.

    What I did is
    - opened a x86 build environment by execution SetEnv.cmd /x86
    - running BuildBoost.bat --toolset msvc-10.0 d:\boost
    which worked and then tried to run
    nmake -f scintilla.mak from win32 directory ( as suggested in readme )
    but I always receive the error

    fatal error C1905: Front end and back end not compatible (must target same processor).
    LINK : fatal error LNK1257: code generation failed
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\Bin\link.EXE"' : return code '0x4e9'
    Stop.

    OK, this points to the fact that there is a library/object which was build with a different
    processor target but I can't figure out what I've done wrong.

    Any ideas?

    Many thx
    Claudia

     
  • Loreia2

    Loreia2 - 2013-02-02

    Hi Claudia,

    just select "Visual studio command prompt", and execute

    ~~~~~~~~~~~~
    nmake -f scintilla.mak
    ~~~~~~~~~~~

    BR,
    Loreia

     
  • CFrank

    CFrank - 2013-02-02

    Hi Loreia,

    thank you for your help and sorry I should have said that I also tried
    Visual Studio 2010 CMD prompt but the messages is the same.
    In the meantime I tried to build with x64 and this worked without a problem.
    Still confused why it doesn't do it with x86.

    Do you have a similar setup?

    Btw. thank you for your excellent work on udl2 - very much appreciated.
    Claudia

     
  • Loreia2

    Loreia2 - 2013-02-02

    I just repeated the same steps, and everything works as expected.

    ~~~~~~~~~~~~~~~~~~~~
    running BuildBoost.bat --toolset msvc-10.0 d:\boost
    nmake -f scintilla.mak
    ~~~~~~~~~~~~~~~~~~~

    No issues form VS command prompt. You will have to wait until Dave sees this thread.
    In the mean time, could you post the content of this directory:

    D:\boost\bin.v2\libs\regex\build\msvc-10.0\debug\link-static\runtime-link-static\threading-multi

    BR,
    Loreia

     
  • Dave Brotherstone

    Do:

    nmake -f scintilla.mak clean
    

    first. That will ensure all of scintilla is clean before you build it. I've had issues like this when there's been something built from a prior build (like a debug build). The nmake build process from Scintilla is a bit brittle, and doesn't cope with multiple output formats.

    Sounds like there's some x64 stuff still built - N++ won't build under x64 without changes, so a clean may do it. If cleaning scintilla doesn't do it, try a clean boost extract.

    Dave.

     
  • CFrank

    CFrank - 2013-02-02

    Hi Dave and Loreia,

    thank you for your help. nmake ... clean did the job - afterwards I was able to
    to run nmake in a x86 env successfully.

    Many thx
    Claudia

     
  • CorruptedFile

    CorruptedFile - 2013-03-23

    Wow, I wish I would have seen this last night after spending hours and hours trying to get a successful build. Followed these instructions and hey what do you know, it works!!!

    Thanks guys!!!