Notepad++ v6.3 released

Don HO
2013-02-03
2013-03-20
1 2 > >> (Page 1 of 2)
  • Don HO

    Don HO - 2013-02-03

    Thanks to the contributions of François-R Boyer, Dave Brotherstone, Ivan Radić (aka Loreia) and Pekka Pöyry, Notepad++ v6.3 is available:
    http://notepad-plus-plus.org/news/notepad-6.3-release.html

    The auto-updater will be triggered in 1 week, if there's no critical issue found.

    Enjoy
    Don

     
  • Jeff Genovy

    Jeff Genovy - 2013-02-03

    Thank you!

     
  • Erik

    Erik - 2013-02-04

    I wonder why Scintilla is no longer updated. I have submitted a bug in the sql lexer there some months ago, but again it has not made its way into notepad++. Afai can see, the LexSQL.cxx is from 2011.

    Thanks & regards
    Erik

     
    • Don HO

      Don HO - 2013-02-04

      Scintilla will be updated in the next major version.

      Don

       
  • Ede_123

    Ede_123 - 2013-02-04

    Fix the bug that file cannot be opened via Explorer context menu when Notepad++ is run as administrator.

    Great! That was bugging me for ages since you have to start Notepad++ as an administrator on Windows to edit system files.

    Could you maybe have a look at [patches:#436] again? That's the only issue left when using Notepad++ for me.

     

    Related

    Patches: #436


    Last edit: Ede_123 2013-02-04
  • EdwTests

    EdwTests - 2013-02-04

    EDIT: Never mind, I just reinstalled the old version and I cannot open the file either.

    -- Original message:
    With 6.3 I can no longer open some "big" files: a text file that is ~160MB in size will now refuse to open, but it used to work with the "end of the world edition". It contains no line breaks, as it is a base64 encoded tab-separated csv file with a over half a million rows. When i open it from the context menu, no message is shown. When i open it from npp's open dialog, i get an error message saying the file is too big.

     
    Last edit: EdwTests 2013-02-04
  • vertical

    vertical - 2013-02-04

    Thanks for the update. I noticed a problem though in both my computers. The program opens windowed but it is set to max. On the very top, I see part of the window because the position is beyond the screen limit. No matter if I change that, every time the program starts, it starts windowed again. See the attached image for details.

     
    • Ices Eyes

      Ices Eyes - 2013-02-05

      Confirmed, here too :)

       
    • Pekka Pöyry

      Pekka Pöyry - 2013-02-05

      I can reproduce this problem. It seems to come from revision 1015, where there is small error in merging my patch (window state is not saved to nppGUI._isMaximized).

       
    • TGW

      TGW - 2013-02-18

      I can confirm this too

       
  • Sawoe

    Sawoe - 2013-02-05

    Hi,

    how can i update to the new version WITHOUT loosing all my personal settings?

     
  • nyobaan.hungkul

    nyobaan.hungkul - 2013-02-06

    Hi, when i'm block uncomment to css file using Ctr+Shift+K, notepad++ has stopped working. Is it bug or because i'm using windows 8 ??

     
  • Neophytus Incognito

    How could I make Notepad++ 6.3 portable again?

    Even if I choose NOT to use %APPDATA%, Notepad++ will create its config folder and stuff there! Apparently, the wiki isn't correct here: Neither the empty file doLocalConf.xml nor system variables (NPP_DIRECTORY) works as described. This is a nuisance!

    Further, it would be even better to perform an unattended installation, with option "Don't use %APPDATA%" selected and "Context Menu Entry" disabled, and if this isn't possible with the NSIS installer, what about switching to MSI for instance?

    Notepad++ might be an attractive editor, but its deployment still needs improvement.

     
  • Greg Newton

    Greg Newton - 2013-02-15

    Is there any way with the new Number styler to define hex digits a-f? I've tried a number of combinations (prefix 0x works but only for numerics). Range and extras don't seem to have any effect in that regard.

     
  • Loreia2

    Loreia2 - 2013-02-15

    Hi Greg,

    you should use Prefix2 and Extras1 to define HEX numbers.
    As explained in documentation:
    http://udl20.weebly.com/numbers.html

    BR,
    Loreia

     
  • Gin

    Gin - 2013-02-16

    NP++ doesn't seem to handle every large folds too well...
    for example folding from line 30 to 19,906
    (Sorry for the sloppy smudge effect but i need to blur out my files and a few other things)

    also either due to how I'm doing my folds or simply the size of them? at some point folds stop folding where specified but instead a few lines down (not shown on the screenshot though)

     
  • Loreia2

    Loreia2 - 2013-02-16

    Hi Erwin,

    a big similar to what you describe was fixed in version 6.3.
    I would like to test this new problem on my machine. Can you send me the file at:

    udlv20 at _ gmail dot _ com

    If file content is sensitive, you can try to send it through password protected ZIP archive.

    BR,
    Loreia

     
  • Crow

    Crow - 2013-02-19

    When I was using replace (ctrl+h) in 6.3, I found that using special character (\n) as replacement in extended search mode will not work properly.

    For example,

    document had: ",\r\n"
    find what: ,\r\n
    replace with: \n

    will get "\\n" instead of "\n"
    This only happens when we use "Replace" button, "Replace All" seem to work fine.


    Forget about above.. please take a look on attachment, I think it would make more sense.

    Thanks and Regards,
    Crow

     
    Last edit: Crow 2013-02-19
    • Byzod

      Byzod - 2013-02-19

      You're using extend mode, change to RegExp mode then it's fine. I think extend mode was done by some trick, which is not as stable as the regular expression engine

       
      • Crow

        Crow - 2013-02-20

        Got it! Awakening me that \n in both extend mode and RegExp had same meaning, why not just use RegExp? Thanks!

         
      • Jozef Szyja

        Jozef Szyja - 2013-02-25

        RegExp is much complicated way, e.g. when I want to replace line endings in scripts, and i need to recognize where one command really ends i look for special characters, using rexp I'm forced to use esc char. I would really need the old funcionality being back.

         
  • Lee

    Lee - 2013-02-19

    Has anyone noticed a folding issue in 6.3? It's working fine in XP SP3 32-bit. However...

    On Win7 SP1 64-bit, [Alt-0] (or View | Fold All) only folds 1 or 2 functions defined in the file. I have to hit [Alt-0] multiple times to fold all functions in each file. This worked fine in previous versions of npp. I have tried uninstalling and reinstalling. I have also tried a portable version. All do the same thing. View | Unfold All appears to work correctly. I have tried this on multiple LISP text files, all of which used to work.

    Update 1: 6.2 and before work fine, but 6.2.1 and later don't. (Tried with zip versions)

    Update 2: 6.2 installed version works "correctly" (the way it always has: [Alt-0] folds ALL functions in file first try)

    Lee

     
    Last edit: Lee 2013-02-19
  • Loreia2

    Loreia2 - 2013-02-19

    Hi Lee,

    I thought this issue was solved in 6.3. Can you send me a sample LISP file, so I could try to reproduce the issue?

    udlv20 at _ gmail dot _ com

    BR,
    Loreia

     
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks