Notepad++ release 6.5

Don HO
1 2 > >> (Page 1 of 2)
  • Don HO

    Don HO - 2013-09-29

    Notepad++ v6.5 is available. Here is the release note:

    Thank Dave Brotherstone, Neomi and Andreas Jonsson for their code contribution of this release.

    Note that the new release will be available for updater after one week (if no critical bug or regression found). Download Notepad++ installer and update it If you don't want to wait.


    • ting

      ting - 2013-10-11

      By the newest update, the names of the "comment" commands have been changed from "Block toggle/stream comment" to "Single line/Block comment". But in contextMenu.xml, these remain unchanged. So I can't find those two commands by right clicking.

    • Don V Nielsen

      Don V Nielsen - 2013-10-15

      Thank you for v6.5. The simple little autocomplete of {} () [] '' & "" is so incredibly useful with Ruby coding. Thanks a lot.

  • bypasser

    bypasser - 2013-09-29

    The column editor bug was not expected to be fixed for now, right?

  • Yaron

    Yaron - 2013-09-29

    Please mention in the Change Log that this version does NOT support switching between LTR and RTL.

    Last edit: Yaron 2013-09-29
  • Dejan Kozina

    Dejan Kozina - 2013-09-29

    There might be something wrong with the minimalist package: I'm getting a 0 byte download...

    • Christophe Meriaux

      Hello Dejan,
      I confirm your problem.
      here is the log of wget :

      --2013-09-29 21:34:30--
      Résolution de (,
      Connexion vers (||:80...connecté.
      requête HTTP transmise, en attente de la réponse...200 OK
      Longueur: 0 [application/x-7z-compressed]
      Sauvegarde en : «npp.6.5.bin.minimalist.7z»
          [ <=>                                                                                       ] 0           --.-K/s   ds 0s
      2013-09-29 21:34:31 (0,00 B/s) - «npp.6.5.bin.minimalist.7z» sauvegardé [0/0]

      Longueur: 0

      • Don HO

        Don HO - 2013-09-29

        The problem has been fixed.
        Sorry for the inconvenient.


  • vosManz

    vosManz - 2013-09-30


    Thanks for the update! Unfortunately, I get an error message and forced close using NP++ 6.5.

    While scrolling in an unmodified PHP file, I get the following error:
    Dialog title: Win32Exception
    An exception occurred. Notepad++ cannot recover and must be shut down.
    The exception details are as follows:
    Code: 0xC0000005
    Type: Access violation
    Exception address: 0x1000AC0A

    After that, I get the question to save a log/dump file. Unfortunately the dump couldn't be created (error 5)

    The problem seems to occur at random. Most of the times when I'm just scrolling in a file.

    Any idea what this could be? I never had this problem in previous versions.


    • vosManz

      vosManz - 2013-09-30

      Same error when using CSS files.
      I am using Windows 8 x64.

      Not sure if it is related, but note that the window that crashes is openend by right-click on a tab, and choose 'copy to new window' (translated from dutch). So I have 2 NP++ windows open. When the new window crashes, the original one is still OK. I can't reproduce this problem (yet) with only 1 window open.

      • Don HO

        Don HO - 2013-09-30

        Have you any plugin installed?


        • vosManz

          vosManz - 2013-10-01

          Yes, I have. However, today I can't reproduce this problem anymore. Maybe the restart of my computer solved it?

          (All plugins have good stability and are up-to-date according to Plugin Manager. Installed plugins: Compare, Converter, Customize Toolbar, DSpellCheck, Emmet, HTML Tag, JSLint, JSON Viewer, JSTool, MIME Tools, NppCrypt, NppExec, NppExport, NppFTP, Plugin Manager, Poor Man's T-Sql Formatter, Python Script, SciMarkerSymbol, Session Manager, Source Cookifier, Spell Checker, Task List, TextFX Characters, Tidy2, ToolBucket, UniversalIndentGUI, XML Tools)

  • Byzod

    Byzod - 2013-10-01

    Awesome, finally multi-paste! But I think it can be improved.

    Reproduce step:
    1. Type few lines, ctrl + click to create some edit points
    2. Ctrl + v to paste something
    3. Ctrl + z to undo paste

    What I expect:
    Pasted content erased, leave edit points you just created

    What happened:
    Pasted content erased, so do your edit points

    I suppose ctrl + z (undo) should go back to the state just right before you paste, restore the edit points too.

  • Andy

    Andy - 2013-10-02

    When Notepad++ 6.5 is pinned to the taskbar and minimized to tray, it doesn't unminimize by clicking on the pinned icon anymore. It seems to be broken since version 6.4.5.

  • Arendell

    Arendell - 2013-10-03

    Font size still bigger than usual

  • MMTsuchi

    MMTsuchi - 2013-10-04

    comparison Shortcuts ("Ctrl+PgDn"....) (from Compare plugin) are overridden by the "switching tabs" function. Regards.


    THEVENOT Guy - 2013-10-04

    Hi, Don,

    Please, see my answer to your last post, in the Notepad++ v6.5 Release Candidate topic, at the address below :

    And have a look to a proposition of FunctionList parser, for .INI files, in the last part of my post. Do you find it interesting ?

    Best Regards,


  • Jim

    Jim - 2013-10-09

    I can't get 6.5 to run (Windows 7, 8 gig RAM, 2 gHz, 64 bit). After I installed it, when it tries to start up, it freezes somewhere along the way, and I have to ctrl-alt-del to force it to shut down. The Process window shows it open, but nothing more happens. Any suggestions?


    THEVENOT Guy - 2013-10-13

    Hello ting,

    It's not too difficult to fix this tiny issue :

    • Open Notepad++, version 6.5

    • Select the choice Settings\Edit Popup ContextMenu, from the Menu bar

    • In the contextMenu.xml file, change the three lines, below :

        <Item MenuEntryName="Edit" MenuItemName="Toggle block comment"/>
        <Item MenuEntryName="Edit" MenuItemName="Stream comment"/>
        <Item MenuEntryName="Edit" MenuItemName="Stream uncomment"/>

    by the three lines, below :

    <Item MenuEntryName="Edit" MenuItemName="Toggle Single Line Comment"/>
    <Item MenuEntryName="Edit" MenuItemName="Block Comment"/>
    <Item MenuEntryName="Edit" MenuItemName="Block Uncomment"/>
    • Save the changes of the contextMenu.xml file

    • Re-start the last version of Notepad++

    Enjoy our loved editor !



    Last edit: THEVENOT Guy 2013-10-13

    AL DOUGLAS - 2013-10-14

    Ever since I updated to npp 6.5, I haven't been able to have multiple tabs open ... As soon as I update something and save it in any one of the tabs, I get a Windows message that "Notepad++: a free (GNU) source code editor has stopped working", and Windows will close the program and notify me if a solution is available.
    The problem also occurs if I have a single tab, save it, close it, then open a new file so I still only have one tab. As soon as that new file comes up, I get the message above.

    I'm running npp 6.5 on a fully up-to-date Vista 32-bit desktop.

    Has anyone else run into this problem, or am I the lucky one?

    Last edit: AL DOUGLAS 2013-10-14
  • saulius

    saulius - 2013-10-17

    On coffee files I am getting error message with title 'Editor':
    message='langs[...]' is null or not an object
    description='langs[...]' is null or not an object

    I am sure it's related to added coffeescript support. Just not sure how to fix it. Thanks

  • saulius

    saulius - 2013-10-18

    The bug is caused by XML.js file which sits in 'Notepad++\plugins\jN\includes\'. So I moved it to disabled and alert disappeared. Anyway would be nice to remove it till next upgrade. Thanks. Take care.

  • 7GOLEM7

    7GOLEM7 - 2013-10-26

    Notepad++ v6.5 not convert UTF-8 (wo BOM) to ANSI if file contains only Latin alphabet.
    Add in text for example "Привет" problem disappears.

  • Lewistrick

    Lewistrick - 2013-10-30

    There are two small problems with Notepad++ on my computer.
    First, when searching through a document, it only matches results below the cursor. I don't want to click the beginning of a document before searching.
    Second, the mouse cursor won't change into a 'text-edit' cursor. Most of the times, it's just a mouse pointer. Sometime's it's a 'change-window-size' cursor.

1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks