Line Number Display Problem

2006-03-15
2012-11-13
  • Nobody/Anonymous

    Notepad++ cannot display the line number properly when a file contains >= 100000 lines. The most significant digit(s) will be truncated. Please fix it.

     
    • Nobody/Anonymous

      I also just discovered the same problem, but to me it appears that Notepad can handle lager numbers than 100 000. The display area for the numbers just seems to be too narrow. Cause the first line numbers are shown as "1", "2" etc, and the numbers greater than 99 999 are displayed as "00000", "00001", "00002" and so on.

       
      • Nobody/Anonymous

        Note: It isn't very common to have source files with more than 10000 lines (Actualy, i try to always keep the number bellow 2000). However, if you have a source file with more than 100000 lines - you should realy think about breaking it into smaller files. This is not only for proper Notepad++ line numbers - it will be easier for you to read them, it will compile faster and so on.

        PS: Notepad++ *is* code editor.

         
        • Nobody/Anonymous

          From the main about page for notepad++: http://notepad-plus.sourceforge.net/uk/about.php

          "Notepad++ is a free source code editor (and Notepad replacement), which supports several programming languages, running under the MS Windows environment."

          I have run into this problem when looking at log files.  If this is to be a notepad replacement, then I would want it to properly display line numbers.  This has bitten me a few times today alone.

           
          • Nobody/Anonymous

            Does ^G (goto line#) work OK on these large
            line-count files ?
            Worth checking it is a display only problem and after fixing that, everything will be ok ?

            jmg_

             
            • Nobody/Anonymous

              A workaround (which may also suggest the nature of the problem):

              While you have the large file open, open the Settings>Preferences popuup, then click the 'Edit components' tab, uncheck the 'Display line number margin', close the popup, then open the popup again and recheck the 'Display line number margin' box.  You should now see the line number margin expanded in width to show the full line number.

               
      • Nobody/Anonymous

        You can see more of the line number when you Zoom Out but the down side is its harder to read.  Just worked on a file with 3.1 million lines and you could just make out the line number.

         
        • Nobody/Anonymous

          Such large line counts are not likely to be source code, but generated reports and listings,that need to be viewed, or datafiles that need editing.

          Suggestion would probably be to make the line-field line count aware, and scale it to suit. smaller files could use fewer columns. ?

          jmg_

           
    • Nobody/Anonymous

      I did so.

      But I prefer working with NPP, even to watch large docs with up to 3million lines, too ;)

      But still to say:

      KeepOnCodein'
      You`re doing great work with this 'little thing' :)
      Thank you.

      Greetings!

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks