WM_CREATE exception when trying to open

Anonymous
2012-01-07
2013-01-24
  • Anonymous - 2012-01-07

    Hello guys!

    Recently, I've noticed a very odd phenomenon. Whenever I try to launch Notepad++, I get a WM_CREATE error. This is what the window looks like:

    Any idea what this problem is? I use Notepad++ extensively (I am a developer) and help on this issue would be very appreciated!

     
  • Anonymous - 2012-01-07

    You have too many windows open.  Close some and try again.

     
  • Anonymous - 2012-01-07

    Thanks for the answer! (Seriously, THANKS!)

    But it's not working…it does it even when i don't have any windows open….I've also noticed that the only time Notepad++ doesn't do this is in Safe Mode.

    Any other ideas? Thanks in advance. :/

     
  • Anonymous - 2012-01-07

    Also: in an attempt to give possible helpers ( :D ) an insight into my issue, here's a screenshot of Task Manager (GDI Objects, Handles, & Threads) at the time of error:

     
  • Anonymous - 2012-01-07

    And once again, I'm really sorry for the repeated replies (I'll stop now, promise!) but I wanted to mention that this error began after an attempted update to the latest version of Notepad++. I've tried downgrading, upgrading, etc., to no avail…which is why I also want to ask how would I go about COMPLETELY clearing Notepad++ out of my system. Thank in advance!

     
  • Dave Brotherstone

    I'm pretty sure this is an old plugin that expects a WM_CREATE message, but doesn't get it (it was turned off in a newer version of N++).  Remove your plugins (rename your plugins directory, for instance), and try again. 

    Assuming that works, then it's just a matter of identifying which one.  Remove them one by one, or remove them all and put them back one by one (I'd just rename each one from .dll to .dlx, then put them back slowly until you get the error again).

    Also, check for plugin updates in plugin manager - it's possible the error has been fixed in an update.

    Cheers,
    Dave.

     
  • Anonymous - 2012-01-09

    Thanks Dave! That worked.

     
  • Anonymous - 2012-01-09

    Hmm, OK Dave, this is weird - I used the standalone extract version of Notepad++, which worked, but now, it's doing the the WM_CREATE thing again D:

     
  • Henri Monnier

    Henri Monnier - 2012-08-03

    I'm getting this error on an XP Pro SP1 PC that has never had Notepad+++ installed on it. I am looking for suggestions on how to clear this error. I first loaded the latest release, got the error, deleted the notepad+++ folder, then loaded a V5 release , and received the same error.
    Your thoughts????
    Henri

     
  • Karl Huldinger

    Karl Huldinger - 2013-01-05

    One year later, I have the same problem...
    On my Windows 7 32bit system Notepad++ is not running anymore,
    I tried everything:
    - renaming plugin folder / removing plugins
    - deleting Notepad with reg cleaner programs and reinstalling older versions
    - run in safe mode

    nothing is working, I keep getting the "WM_CREATE" error window.
    Any ideas?
    Thanks

     
  • Loreia2

    Loreia2 - 2013-01-05

    Hi,

    I had this same error message recently in UDL module. I traced it down to a void pointer in UDL dialog. Generally, I can only say that this kind of error can't possible be fixed without reproducing the issue on developer's computer.

    So, we need either:
    a) detailed and reliable description how to reproduce the issue
    b) someone who can reproduce it should try to follow the code execution in debugger

    Also, anyone who is having this problem, should also report if this is reproducible with portable version.

    BR,
    Loreia

     
  • mm06610

    mm06610 - 2013-01-24

    Hello, i have also got the "WM_create" error window.
    in my environment (windows XP), problem was caused by Comodo firewall.
    The settings was set to ask for every new action from a program (the "paranoid mode"), but it seems that the firewall has forgot some of the authorizations that was set for notepad++ files.
    i have fixed the issue by doing the following:
    - open firewall settings, "defense+" tab
    - open the "trusted files" list, and remove all entries for notepad++ directory, click OK
    - open the "computer security policy" and remove all entries for notepad++ directory, click OK
    next time i have started notepad++, the firewall asked me, i selected "trusted", remember, and everything is fine now.

    hope this helps.