line selection

bon ami
  • bon ami

    bon ami - 2006-05-31

    if i disable line number margin to be displayed, and keep bookmark margin on, i cannot hardly click left margin to select line, since the cursor does not change between bookmark margin and the place that i can click to select line.
    all in all, i recommend two. 1, cursor displays different where i click to bookmark and where i click to select line. 2, give more space to select whole line in the case bookmark margin may be decreased. all these are on the basis that i keep bookmark margin on and line numbers off to save work space.
    thank you.

    • Anonymous - 2006-05-31

      I had an editor once, in which there was a separate "line selection" margin - I could click on it to select a whole line. In fact, I still have that habit and frequently subconsciously click on the folding margin to select a line. Of course this makes bookmark instead and thus turns a single click into a series of three clicks - another one to delete the bookmark and then the final, precise one to select a line.

      • Nobody/Anonymous

        Me too, sometimes I want to select a line and end up bookmarking it.

        Maybe the bookmark "column" should be placed at the left of the line numbers.

        And for bookmarks, either a cursor change or a hover effect could help.


    • bon ami

      bon ami - 2006-07-24

      not seeing this problem CORRECTED, i'm afraid i cannot bear to use notepad++.

    • mykro76

      mykro76 - 2008-06-27

      I wanted to select the current line and did not even know about this magic hotpoint feature until I found this thread.

      Perhaps a context menu option "Select current line" should be provided, which does the same thing.  Perhaps even with a shortcut key as well.

    • Nobody/Anonymous

      Tripleclicking a line works well. Its like doubleclick but then three button presses, the whole line will be selected


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks