Vertical line spacing (configurable?)

2011-03-28
2014-06-12
  • Steven Reddie
    Steven Reddie
    2011-03-28

    Hi,

    I love Notepad++, but the one thing that stops me from using it as a notepad replacement is that I can't fit as much on the screen as I can with notepad.  Even if I switch to a small font in Np++, the line height does not change.

    Is line spacing / line height already configurable?  If so, where is the option.  If not, can this please be added?

    Regards,

    Steven

     
  • bbluemel
    bbluemel
    2011-03-28

    Have you got a separate size set in Settings - Style Configurator - Global Styles - Line number margin?

     
  • Bob Uncle
    Bob Uncle
    2011-03-29

    Steven, have you tried using the zoom options in the View menu instead of changing the font size?

    - Bob

     
  • cchris
    cchris
    2011-03-31

    Don't forget fullscreen and post-it mode to maximise the text area.

    CChris

     
  • tim0thy
    tim0thy
    2011-05-30

    This is what I found in npp5.9. Set Settings - Style Configurator - Global Styles - Default Style. Change Font Name and Font Size as desired. In my case I changed this to ProggyTiny 8 - 150 lines of  text - fantastic! I also changed the font in Line Number Margin and Global Override to ProggyTiny 10 to see if that it would screw it up - it didn't.
    Hope this helps…

     
  • Andrew Heale
    Andrew Heale
    2012-05-03

    Same problem here; in my case the culprit was in Settings - Style Configurator - Global Styles - Brace highlight style (which seems to be set by default in npp 6.1.2). But any of the global styles that have a font size can cause this problem. You have to make sure they're all small or blank.

    Andrew

     
  • Errol Smith
    Errol Smith
    2014-06-12

    Thanks Andrew, it was indeed the obscure Brace highlight style global setting. Changing the font size here to <blank> fixed everything.

    IMO having that set is a poor default setting and should be changed!