Notepad++ v5.6.6

Don HO
2010-01-26
2012-11-13
  • Don HO

    Don HO - 2010-01-26

    As I promised, the installer is available in this new release.

    Don

     
  • Ivan.Zhang

    Ivan.Zhang - 2010-01-26

    Thank you for your quick action.

     
  • iycgtptyarvg

    iycgtptyarvg - 2010-01-26

    Why is the HexEditor plug-in being disabled when installing this program? Without a hex editor I would have to go back to Ultra-Edit.
    I much prefer Notepad++ because it is free, but a built-in hex editor is a must.

     
  • cchris

    cchris - 2010-01-26

    Because it can crash Notepad++ in some rare cases, even though 0.9.5 is definitely more reliable than earlier versions.

    Integratin the functionality in N++? That would be nice, but we' need more active, fulltime developers for free, plainly.

    CChris

     
  • Daisy Olla

    Daisy Olla - 2010-01-26

    When will we see these beautiful bookmarks from Solution # 2 (if they make a really hard then at least from Solution # 3)

    Best regards, Daisy

     
  • Jocelyn Legault

    Jocelyn Legault - 2010-01-26

    I don't see what benefits having HexEdit built it would bring. IMO, it's a perfect candidate for a plugin (which it is).
    cchris: I don't know about v. 0.9.5, but I had 100% reproducible crashes when doing a compare with previous versions of the hex editor.
    iycgtptyarvg: If you have the plugin manager installed, installing the latest version of the Hex Editor should be a breeze.

     
  • phi2x

    phi2x - 2010-01-26

    I see that the Light Explorer Unicode version is not included anymore with Notepad 5.6.6.
    Is there any reason to this rejection ?

     
  • Jocelyn Legault

    Jocelyn Legault - 2010-01-26

    phi2x: AFAIK, it's because it's unstable.

     
  • Xia Zheng Xin

    Xia Zheng Xin - 2010-01-30

    post the changelog ,plz

     
  • Don HO

    Don HO - 2010-01-30

    AutoUpdater for v5.6.6 is triggered.
    The updater will work only for v5.6.4. You have to download and install v5.6.6 if your Notepad++ version is older than v5.6.4.
    Sorry for the inconvenient.

    Don

     
  • Gregory

    Gregory - 2010-01-30

    v5.6.6 Case-insensitive search doesn't work with cyrillic charset again  (I suppose with all non-western charcaters).

     
  • Collin Loho

    Collin Loho - 2010-01-30

    v5.6.6 Case-insensitive search doesn't work with cyrillic charset again (I suppose with all non-western charcaters).

    work for me

     
  • cchris

    cchris - 2010-01-30

    Confirmed, 5.6.5 was working properly.

    CChris

     
  • Alan Mintaka

    Alan Mintaka - 2010-02-24

    joleg74,
    The version of the Hex Editor I had been running was 0.9.5.  When I was installing NPP 5.6.7, I too saw the message about the Hex Editor being disabled because of "Stability Issues".  However, in NPP version 5.6.7, the Plugin Manager doesn't show the Hex Editor as one of the available plugins - so it can't be restored that way.  I kept a copy of the downloaded ZIP file for the Unicode version of the Hex Editor, so what I did to restore it was just copy the Hex Editor DLL from the ZIP file back into the Plugins directory.  It seems to be working fine, at least for plain text files.

    iycgtptyarvg, why not give that method a try?  I'm not a power user by any means, but I occasionally find uses for viewing files in hex.  For my purposes, version 0.9.5 (Unicode) works OK with NPP 5.6.7.

    Have a good one,
    Big Al Mintaka

     
  • Dave Brotherstone

    @alanmintaka, Plugin Manager will show hex editor, you just need to click settings, and enable the "Show unstable plugins".  Having this disabled by default was a precondition for bundling with N++.

    Cheers,
    Dave

     
  • cchris

    cchris - 2010-02-24

    @Dave:
    Can you update PM for CCompletion v1.17 before I forget and clobber it back with v1.15, as PM is trying to?
    Thanks

    CChris

     
  • Alan Mintaka

    Alan Mintaka - 2010-02-24

    Thanks davegb3,
    OK, I see how that works now.  I had already installed the Hex Editor per what I described in my previous post, so it still doesn't appear in the list; but I do see the other unstable plugins show up when I enable that option in settings.  It's good to know it's there for future reference, thanks once again.

    Big Al Mintaka

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks