Problem in Sending Mail.

Help
2011-09-09
2014-04-17
  • BIkram Kawan

    BIkram Kawan - 2011-09-09

    I have recently Setup Nocc in my server. I can receive messages but facing problem in sending. I am confused in config file.
    For sending
    If your are facing problem in seding mail . Try just leave blank in default_smtp_server. NOCC works like charm.

    $conf->default_smtp_server = ' ';
    $conf->default_smtp_port = 25;

     
  • Christian Wami

    Christian Wami - 2014-04-16

    I have this message: Une erreur est survenue : : Connection timed out

     
    • Oliver Heil

      Oliver Heil - 2014-04-16

      Your configuration for sending mail is properly set up?

      Oli

       
  • Christian Wami

    Christian Wami - 2014-04-17

    all set up is fine just about sending, i can't send a mail or upload a file! i don't knows why?

     
    • Oliver Heil

      Oliver Heil - 2014-04-17

      What is your smtp configuration?

       
  • Christian Wami

    Christian Wami - 2014-04-17

    this is my config, all setup is right read, delete, ... but a can't send or upload a file i have this message: "Une erreur est survenue,Possibilité d'attaque depuis le fichier uploadé, Arrière "
    My language is=french.

    but anywhere, i can use correctly with the same servers (address/config) is right!

    So this is my config.php, i don't where is the problem with smtp?

    $conf->domains[$i] = new stdClass();
    $conf->domains[$i]->show_as = 'tw';
    $conf->domains[$i]->domain = 'teamworkcd.com';
    $conf->domains[$i]->in = 'imap.one.com:143';
    $conf->domains[$i]->smtp = 'send.one.com';
    $conf->domains[$i]->smtp_port = 25;
    $conf->domains[$i]->login_with_domain = true;
    $conf->domains[$i]->login_with_domain_character = '@';
    $conf->domains[$i]->login_prefix = '';
    $conf->domains[$i]->login_suffix = '';
    $conf->domains[$i]->login_aliases = array();
    $conf->domains[$i]->login_allowed = array();
    $conf->domains[$i]->smtp_auth_method = 'LOGIN';
    $conf->domains[$i]->imap_namespace = 'INBOX.';
    $conf->domains[$i]->have_ucb_pop_server = false;
    $conf->domains[$i]->quota_enable = false;
    $conf->domains[$i]->quota_type = 'STORAGE';
    $conf->prefs_dir = '';
    $conf->prune_sessions = 1;
    $conf->tmpdir = '/tmp';
    $conf->debug_level = E_ALL & ~E_NOTICE;
    $conf->memory_limit="20M";
    $conf->base_url = '';
    $conf->crlf = "\r\n";
    $conf->default_smtp_server = '';
    $conf->default_smtp_port = 25;
    $conf->allowed_char='';
    $conf->enable_logout = true;
    $conf->vhost_domain_login = false;
    ...
    $conf->send_delay = 30;

    $conf->default_smtp_server = '';
    $conf->default_smtp_port = 25;

     
  • Christian Wami

    Christian Wami - 2014-04-17

    Think you! but now i see this:

    "Une erreur est survenue : : 503 5.5.1 Error: authentication not enabled "

     
  • Christian Wami

    Christian Wami - 2014-04-17

    ok! think you for that! Sending mail's ok now! just the last problem with "upload file"! i see the same message: "Une erreur est survenue,Possibilité d'attaque depuis le fichier uploadé, Arrière "

     
    • Oliver Heil

      Oliver Heil - 2014-04-17

      Make sure that the directory defined with
      $conf->tmpdir
      is accessible and writable by the webserver.
      For file upload you must define a directory here.

       

Log in to post a comment.