Background processing and autofs

Help
2013-08-16
2014-05-26
  • Todd Tavasci

    Todd Tavasci - 2013-08-16

    I have noticed on my RHEL6 systems where we run nmon as a background process that any NFS mount point that was mounted by autofs and is currently in the mount table when the nmon background process is started will continue to be remounted by nmon every time it samples. autofs mounts that occur after the background process is started are not affected and unmount when idle as expected. We kill the active nmon process at midnight and start a new one for the next day. Over a period of time we are seeing more and more autofs mount points getting stuck due to this. We are running nmon 14g. I've been reviewing the documentation but so far I've not come across anything that would seem to be related to this. As a temporary work-around we are looking at inserting a restart of autofs into the nightly script that restarts nmon for the next day to clear out as many idle mounts as possible, but I'm thinking there has to be something better than that long term. Appreciate any ideas or suggestions.

    -Todd Tavasci
    ttavasc@rei.com

     
    • Marii Shirouzu

      Marii Shirouzu - 2014-05-26

      Hello everyone,

      I am in a similar situation, and would like to have your help.

      Do you have any option for nmon command, to disable status check for remote file systems?
      I have noticed that AIX nmon doesn't check remote file systems, but could not find it's Linux equivalent option.

      In my case, nmon check interval is shorter than automount timeout settings, and remote file system will be kept always mounted, while our application requirement states that remote file system should be unmounted if unnecessary.

      I really appreciate your help and suggestions.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks