Cound and second values... don't works?!

  • Anonymous - 2010-11-24


    i've tried nmon on redhat 5.5 and i'm facing a problem about -s and -c values…  it appears process always running after configured delay…
    -s15 -c4 = 1 minute? right?
    so, why process still exist after 4 or 5 minutes?? (don't know exactly how many times…)


  • Anonymous - 2010-11-24

    And -X does not result of one hours of logs…
    Started @5:10PM, last touch on file is 6:25PM actually…

    is there knowed problem about that?

  • Nigel Griffiths

    Nigel Griffiths - 2010-11-27

    Can you state which version of nmon you are running ? Try nmon -V

    Can we have the whole command that you typed in?
    I have just run:  nmon_power_rhel55 -f -s15 -c4
    and it ran for one minute plus a faction of a second that it takes for it to gather the configuration- it does this at the start.
    If your machine is massive - typically 100's of disks it can take some time - then nmon might over run a few seconds.

    Check the output file and the
    lines tell you what nmon thinks its been asked to do.

    Perhaps, nmon is getting stuck with some command hanging, although the vast bulk of the data comes from /proc.
    Think about this /proc is not actually a file system but a number of device driver so it could hang too.

    -X might be the same sticking problem the only different is the interval=30 seconds and snapshot =120

    Take a look at the end of the nmon output file with "tail -f FILENAME" and watch the output arrive once per snapshot time
    or "grep ZZZZ FILENAME" and see the times at which nmon saved data.

    If nmon is sticking then its a Linux problem that we can investigate further.

    Hope this hels, Nigel Griffiths

  • Anonymous - 2010-11-29


    Thanks for your answer.

    nmon version is 14a

    i've tried your command : -f -s 15 -c 4 : it works correctly : 1 minute of log & process.

    Maybe i've not correctly understood -t or -r paramters? is there one fo them which involve longer log than values defined by -s and -c ?



Log in to post a comment.