Gene Heskett - 2008-06-04

Greetings Guys;

Even after fixing the joydrv_655xx stuffs in my copy, I can't build a bootable disk using a joydrv that properly addresses my hardware.

The i2xo from krnp2 is there, and in my copy of joydrv I have additional calls to <D.BtBug such that it now displays i2xo++3+4 indicating that joydrv sucessfully init'ed itself as the last '4' is immediately in front of the puls cc,pc than ends the init sequence here in joydrv:

00170                    * add i2xo++3+4
00171    0105 347F                      pshs      a,b,x,y,u,cc,dp
00172    0107 8634                      lda       #'4                 add irq su
00173    0109 9D5E                      jsr       <D.BtBug
00174    010B 357F                      puls      a,b,x,y,u,cc,dp
00175    010D B7FF7F                    sta       >MPI.Slct           set MPI sl
00176
00177                    * BUG FIX: InitExit is now here... was TermExit...
00178                    * GH - 06/01/2008 looks as if no errors are reported if
00179                    * GH - and mine isn't showing up in irqs output...
00180    0110 3581       InitExit       puls      pc,cc               recover or

But I never see the next 'C' from krn2, and I've added enough stuff between the 'o' and the 'C' to run through pqrs before it outs the 'C'.

None of them are printing.  That means (I think) it is never returning from the I$OPEN here, although the stack could be fscked at the above puls pc,cc too.  I'll run through that again but I think its clean, I've scribbled all over two of those printouts now.

From krnp2:

00199    0040 347F                      pshs      a,b,x,y,u,cc,dp
00200    0042 866F                      lda       #'o                 tried open
00201    0044 9D5E                      jsr       <D.BtBug
00202    0046 357F                      puls      a,b,x,y,u,cc,dp
00203                    * worked, I see i2xo
00204                    * but now I've added regs save
00205                    * we'll see on next build
00206    0048 8603                      lda       #UPDAT.             get file m
00207    004A 103F84                    os9       I$Open              open path
00208
00209    004D 347F                      pshs      a,b,x,y,u,cc,dp
00210    004F 8670                      lda       #'p                 tried open
00211    0051 9D5E                      jsr       <D.BtBug

The Mamou Assembler Version 01.00      06/04/2008 08:53:58      Page 003
krnp2 - NitrOS-9 Level 2 Kernel Part 2

00212    0053 357F                      puls      a,b,x,y,u,cc,dp
00213                    * do I see i2xop?

And the answer is no.  How do I next proceed?  I'm not even sure what its trying to I$OPEN at this point.

Hints pursued, not always with glee at this point.  Getting frustrated...

--
Gene