Compiling for Debian

  • x1Developer

    x1Developer - 2013-09-14

    Hi, everyone!
    First I compiled ngspice for cygwin and then I decided to compile for Linux.
    I tried to compile last stable ngspice (rework25) for Debian 7 and got error during make command execution.

    make[2]: Entering directory /home/user/ngspice_preinst/ngspice/release/src' CC ngspice-main.o CC ngspice-conf.o CC ngspice-ngspice.o CCLD ngspice frontend/plotting/.libs/libplotting.a(plotcurv.o): In functionplotinterval':
    /home/user/ngspice_preinst/ngspice/release/src/frontend/plotting/../../../../src/frontend/plotting/plotcurv.c:333: undefined reference to ft_peval' /home/user/ngspice_preinst/ngspice/release/src/frontend/plotting/../../../../src/frontend/plotting/plotcurv.c:335: undefined reference toft_peval'
    maths/cmaths/.libs/libcmaths.a(cmath4.o): In function cx_deriv': /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:380: undefined reference toft_polyderiv'
    /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:396: undefined reference to ft_peval' /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:410: undefined reference toft_peval'
    /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:287: undefined reference to ft_polyderiv' /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:294: undefined reference toft_peval'
    /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:305: undefined reference to ft_polyderiv' /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:312: undefined reference toft_peval'
    /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:322: undefined reference to ft_peval' /home/user/ngspice_preinst/ngspice/release/src/maths/cmaths/../../../../src/maths/cmaths/cmath4.c:324: undefined reference toft_peval'
    maths/fft/.libs/libmathfft.a(fftext.o): In function rspectprod': /home/user/ngspice_preinst/ngspice/release/src/maths/fft/../../../../src/maths/fft/fftext.c:160: undefined reference tocvprod'
    maths/poly/.libs/libpoly.a(interpolate.o): In function putinterval': /home/user/ngspice_preinst/ngspice/release/src/maths/poly/../../../../src/maths/poly/interpolate.c:25: undefined reference toft_peval'
    maths/poly/.libs/libpoly.a(polyfit.o): In function ft_polyfit': /home/user/ngspice_preinst/ngspice/release/src/maths/poly/../../../../src/maths/poly/polyfit.c:92: undefined reference toft_peval'
    collect2: error: ld returned 1 exit status
    make[2]: [ngspice] Error 1
    make[2]: Leaving directory /home/user/ngspice_preinst/ngspice/release/src' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/home/user/ngspice_preinst/ngspice/release/src'
    [all-recursive] Error 1

    What to do with this problem? As much as could understand, the problem is with the some packages which are not installed or which have versions, which differ from those what needed for ngspice.
    But from this I could understand nothing.

    My configure command was:
    ../configure --with-x --enable-xspice --disable-debug --enable-cider --enable-openmp --enable-xgraph --enable-adms

    Everything was OK.

    Thanks for your help.



    ngspice: ngspice

  • Holger Vogt

    Holger Vogt - 2013-09-14

    Perhaps this helps:

    ./ --adms
    from the ngspice directory and then cd to release for
    ../configure ...


  • Robert Larice

    Robert Larice - 2013-09-14

    I think xgraph is real ancient, please drop that and try again,
    I haven't compiled with that for a long time.
    furthermore don't use adms except you realy know what you are doing.
    of course you would have to invoke ./autogen without the --adms option then.

    when you still have issues, then please start fresh and "attach" the whole
    output from
    ./configure ...
    because the html business of these forum posts harm readability.


  • x1Developer

    x1Developer - 2013-09-14

    Thank you for your help. Everything works (with adms and xgraph). The only problem was that I took ngspice directory from cygwin where ngspice was already compiled. So, I apologize, some files from cygwin version were not rewritten during compiling and linker tried to link files from different versions (cygwin and debian). It was the reason of error. I took archive from ngspice site and everything works now.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks