#11 Patch to compile with gcc 4.2.2

closed-fixed
None
5
2008-03-03
2007-12-05
No

Here's a patch to compile with gcc 4.2.2. Also, in a separate file, a little "const" sprinkling elminates a great number of warnings.

Discussion

  • Frederick Bruckman

    Must now supply all arguments to std::map &c in "template template" templates.

     
  • Frederick Bruckman

    Logged In: YES
    user_id=803104
    Originator: YES

    File Added: nget-gcc-4.2.2-warnings.diff

     
  • Matthew Mueller

    Matthew Mueller - 2008-03-03
    • assigned_to: nobody --> donut
    • status: open --> closed-fixed
     
  • Matthew Mueller

    Matthew Mueller - 2008-03-03

    Logged In: YES
    user_id=65253
    Originator: NO

    Thanks, I've applied nget-gcc-4.2.2-warnings.diff. I went with a slightly different approach for the error fix, but having your patch (and the debian one) to look at was helpful.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks