#91 Debina stable amd64 fails to start

v1.0 (example)
closed
nobody
5
2012-04-27
2012-03-04
No

Tested with the nixnote-1.2_amd64.deb package. Needs to require ia32-sun-java6-bin and point to it?

console output says it all:

$ nixnote
Exception in thread "main" java.lang.ExceptionInInitializerError
at java.lang.Class.initializeClass(libgcj.so.10)
at com.trolltech.qt.QtJambiObject.<clinit>(QtJambiObject.java:60)
at java.lang.Class.initializeClass(libgcj.so.10)
at java.lang.Class.initializeClass(libgcj.so.10)
at java.lang.Class.initializeClass(libgcj.so.10)
at java.lang.Class.initializeClass(libgcj.so.10)
at java.lang.Class.initializeClass(libgcj.so.10)
Caused by: java.lang.RuntimeException: Loading library failed, progress so far:
Unpacking .jar file: 'qtjambi-linux64-gcc-4.5.2_01.jar'
Checking Archive 'qtjambi-linux64-gcc-4.5.2_01.jar'

at com.trolltech.qt.internal.NativeLibraryManager.loadNativeLibrary(NativeLibraryManager.java:431)
at com.trolltech.qt.internal.NativeLibraryManager.loadQtLibrary(NativeLibraryManager.java:355)
at com.trolltech.qt.Utilities.loadQtLibrary(Utilities.java:140)
at com.trolltech.qt.Utilities.loadQtLibrary(Utilities.java:136)
at com.trolltech.qt.QtJambi_LibraryInitializer.<clinit>(QtJambi_LibraryInitializer.java:56)
at java.lang.Class.initializeClass(libgcj.so.10)
...6 more
Caused by: java.lang.RuntimeException: Failed to unpack native libraries, progress so far:
Unpacking .jar file: 'qtjambi-linux64-gcc-4.5.2_01.jar'
Checking Archive 'qtjambi-linux64-gcc-4.5.2_01.jar'

at com.trolltech.qt.internal.NativeLibraryManager.unpack(NativeLibraryManager.java:368)
at com.trolltech.qt.internal.NativeLibraryManager.loadLibrary_helper(NativeLibraryManager.java:437)
at com.trolltech.qt.internal.NativeLibraryManager.loadNativeLibrary(NativeLibraryManager.java:426)
...11 more
Caused by: org.xml.sax.SAXParseException: trying to load: 'linux64', expected: 'linux32'
at gnu.xml.stream.SAXParser.parse(libgcj.so.10)
at javax.xml.parsers.SAXParser.parse(libgcj.so.10)
at javax.xml.parsers.SAXParser.parse(libgcj.so.10)
at com.trolltech.qt.internal.NativeLibraryManager.readDeploySpec(NativeLibraryManager.java:506)
at com.trolltech.qt.internal.NativeLibraryManager.unpackDeploymentSpec(NativeLibraryManager.java:524)
at com.trolltech.qt.internal.NativeLibraryManager.unpack_helper(NativeLibraryManager.java:392)
at com.trolltech.qt.internal.NativeLibraryManager.unpack(NativeLibraryManager.java:363)
...13 more
Caused by: com.trolltech.qt.internal.WrongSystemException: trying to load: 'linux64', expected: 'linux32'
at com.trolltech.qt.internal.NativeLibraryManager$XMLHandler.startElement(NativeLibraryManager.java:242)
at gnu.xml.stream.SAXParser.parse(libgcj.so.10)
...19 more

Discussion

  • Randy Baumgarte

    Randy Baumgarte - 2012-03-04

    Please double check that you are running a 32 bit version of Java. Some people using a 64 bit version of Linux use a 32 bit Java, but some use the 64 bit version of Java. Since the deb checks the Linux architecture I can only package one version of Jambi. It made the most sense to package the 64 bit version of Jambi in the 64 bit deb.

    If you are using a 32 bit Java the easiest thing to do is to remove the version of NixNote completely and download the 32 bit tar file. In the tar file there is an install script. Run the script and you should be fine.

     
  • Randy Baumgarte

    Randy Baumgarte - 2012-04-05

    Please let me know if you are still having a problem, otherwise I'll close this ticket.

     
  • Randy Baumgarte

    Randy Baumgarte - 2012-04-27

    No response. Closing. Please reopen if you are still having a problem.

     
  • Randy Baumgarte

    Randy Baumgarte - 2012-04-27
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks