Can't install

  • pobhockle

    pobhockle - 2008-06-03

    I've insatlled the latest WinPcap and can't get NetworkMiner-0.84 to install. After double-clicking the .exe I get an error of 'The application failed to initialize properly (0xc0000135). Click OK to terminate the application.'

    Is there something else I need to install to run NM?


    • Erik Hjelmvik

      Erik Hjelmvik - 2008-06-03

      NetworkMiner doesn't have to be installed, it should be possible to run it directly after unzipping it. Could you please give some more details of why you cannot start NetworkMiner?

      One known issue is that NetworkMiner and other .NET applications do not have the proper permissions to be started from a network share, it normally works better if you place it locally or on some sort of removable media instead.
      If you must run it from a network share then you need to set up the .NET Framework to trust the network location where you've placed NetworkMiner. For details of how to create a new Code Group and assign full trust to it see:

      • pobhockle

        pobhockle - 2008-06-03

        OK, I thought that was the install. It was just the run .exe. Cool. 'Cept it didn't load.

        From what you said, I looked up .NET and then got onto .NET Framework.. That's what I needed and I think your page needs to be updated to show that.

        So, it loaded after installing .NET Framework 2 but it doesn't do anything! Least I can't get it to. Since you're so good and quick, could you tell me if it would be possible to capture the videos here please? This is why I wanted to try it out becasue no other peice of software has been able to capture these videos.


    • Erik Hjelmvik

      Erik Hjelmvik - 2008-06-06

      I took a look at the BBC link you provided and I can tell you that NetworkMiner will not be able to extract the video from VideoGaiden. The reason is that they use the "Real Time Messaging Protocol" (RTMP) for transport of the video data. I haven't implemented this protocol in NetworkMiner, so you'll have to find some other tool where this protocol is implemented (if there is any?)

    • Hank Nussbacher

      Hank Nussbacher - 2008-09-02

      I too get the same error message on only some systems.  On a Win XP SP2 system I get it but strangely enough, in a VMWare Workstation 6.0.4 Win XP SP2 on the same computer, I am able to get NM to work perfectly.

      I have another Win XP SP2 system that runs perfectly as well.  Strange.

      Both run off a disk directly with no network shares.

      Would help if there was some sort of internal error log.

    • Brian Daniel

      Brian Daniel - 2009-04-08

      I'm running Windows Vista 64-bit so the .net install Erik mentioned wont work for my system.

    • OhRama

      OhRama - 2009-06-08

      I have this program running on an Intel machine with Win-XP, SP2 installed. I tried using this on an AMD CPU system and it doesn't seem to capture the data (It does for small files but not big audio / video files as it used on the Intel machine). Does networkminer work on AMD machines and do I need any other plug in? Thanks

      • Erik Hjelmvik

        Erik Hjelmvik - 2009-06-08

        NetworkMiner should work just fine on AMD systems. What is more interesting is what network interface you are sniffing from. Are you using a WinPcap adapter or Raw Socket?

        Please also ensure that you follow the instructions here:


Log in to post a comment.