NM loads but won't set wifi adaptor

Help
Christy
2014-04-21
2015-07-27
  • Christy

    Christy - 2014-04-21

    I've just downloaded networkminer free 1.5.0.0, I'm running it on XP SP3, .net 4.0

    The package loads fine, but when I try to select either of my two wireless adaptors from the dropdown (AR9285 and RTL8187) I get:

    Ensure you have administrator rights (required in order to use socket connections)
    An invalid argument was supplied

    I'm logged in as administrator and no other package has ever had permission issues.

     
  • Erik Hjelmvik

    Erik Hjelmvik - 2014-05-28

    Hi Christy,

    Make sure you start NetworkMiner by right-clicking NetworkMiner.exe and then choose "Run As Administrator" in order to run with Admin privileges.

    Also, to get better results when doing WiFi monitoring we recommend using an AirPcap adapter (from Riverbed) instead your built in wireless network card.

     
  • ingrimmsch

    ingrimmsch - 2014-10-18

    --

     
    Last edit: ingrimmsch 2014-11-06
  • Mitch Miller

    Mitch Miller - 2015-07-27

    I'm seeing a similar issue to Christy's -- trying to debug communication between 2 applications on an XP box.
    I'm logged in as a user with admin privs but get the message

    Ensure you have administrator rights (required in order to use socket connections)
    An invalid argument was supplied

    when selecting the 'MS TCP Loopback interface' from the drop-down.
    I tried right-clicking on the NetworkMiner executable and selecting 'Run as...' then selecting Administrator and supplying the password but still get the error.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks