please report bugs here

2013-04-20
2016-03-26
1 2 > >> (Page 1 of 2)
  • pedro ubuntu

    pedro ubuntu - 2013-04-20


    -=[ BUG REPORTING ]=-

                     "correct way to report a Bug"
    
              1 - describe what netool distro are you using
                  "netool[kali].tar.gz  OR  netool.tar.gz"
              2 - post the error report provided by netool.sh
    

    @Suspicious Shell Activity Labs | r00tsect0r CyberTeam

     
    Last edit: pedro ubuntu 2015-07-25
  • pedro ubuntu

    pedro ubuntu - 2013-05-05

    [ Strahinja Prvulovic ]

    i cannot open webcrawler on your netool...
    I have make chmod +x webcrawer.py
    and all but does not work

    bug report

      [-] (Your choice?):18
      ./netool.sh: 2087: cd: can't cd to /home/haxorworm/opensource
      [~] this module require [webcrawler.py] installed to work
    


     
    Last edit: pedro ubuntu 2015-07-25
    • pedro ubuntu

      pedro ubuntu - 2013-07-03

      soluction

      my tool dont use 'absoluct paths' to work, so it as
      to be installed on the rigth location to work proper...

        install path in linux-ubuntu:
        unpack "opensource.tar.gz" under "/home/username" folder
        example: (home/username/opensource)
      


        install path in kali-linux:
        unpack "opensource[kali].tar.gz" under "/root" folder
        example: (/root/opensource)
      


        install path in backtrack-linux:
        unpack "opensource[backtrack].tar.gz" under "/root" folder
        example: (/root/opensource)
      


      final notes

      your error shows that my tool its not installed in the rigth path

       
      Last edit: pedro ubuntu 2013-11-25
  • pedro ubuntu

    pedro ubuntu - 2013-05-05

    [ Strahinja Prvulovic ]

    module webcrawler.py

    bug report

      Traceback (most recent call last):
      File "./webcrawler.py", line 19, in <module>
      from BeautifulSoup import BeautifulSoup
      ImportError: No module named BeautifulSoup
    
     
    Last edit: pedro ubuntu 2013-10-22
    • pedro ubuntu

      pedro ubuntu - 2013-07-03

      soluction

      install the packet "BeautifulSoup"
      (Beautiful Soup is a Python library for parsing HTML documents).


        "install 'BeautifulSoup' on linux-ubuntu"
      
        sudo apt-get install BeautifulSoup
      
        or: install it using "synaptic packet manager":
      
        python-beautifulsoup
      


        "install 'BeautifulSoup' on kali-linux"
      
        install using "synaptic packet manager"
        python-beautifulsoup
      
       
      Last edit: pedro ubuntu 2013-11-25
  • pedro ubuntu

    pedro ubuntu - 2013-05-07

    [ Andrzej Wysocki ]

    netool gives me a error when installing..
    on backtrack linux distro

    bug report

      package ettercap-gtk is not available, but is referred to by another package.
      This may mean that the package is missing, has been obsoleted, or
      is only available from another source
      E: Package ettercap-gtk has no installation candidate
    
      \033[31m[*] this script required Macchanger instaled to work\033[0m
      \033[32m[!] {wait} downloading macchanger from network... \033[0m
      \033[32m[!] press \033[36m{CTRL+C}\033[0m\033[32m to stop installation \033[0m
    
      Reading package lists... Done
      Building dependency tree 
      Reading state information... Done
      macchanger is already the newest version.
      E: Couldn't find package macchanger-gtk
      \033[34m[+] macchanger {instaled} restarting Script...\033[0m
    
     
    Last edit: pedro ubuntu 2013-10-22
    • pedro ubuntu

      pedro ubuntu - 2013-07-03

      soluction

      ok it seems that ettercap-gtk (ettercap GUI) was removed from repos
      [so install it using ubuntu software center, or synaptic packet manager],

      it seems that macchanger-gtk (macchanger GUI) was removed from repos
      to [so install it using ubuntu software center, or synaptic packet manager],

      another soluction will be:

      (config only for netool.sh-backtrack distro)

      edit the file "netool.sh" and search for
      'Path to instalations and variaveis do script'
      then replace the paths for the rigth ones

        find="/usr/local/share/zenmap"
        find2="/usr/local/share/ettercap"
        find3="/usr/local/share/macchanger"
        find4="/opt/metasploit"
        confE="/etc/etter.conf"
        confD="/usr/local/share/ettercap/etter.dns"
        confP="/usr/local/share/ettercap/etter.services"
        confW="/usr/bin/driftnet"
        confSSL="installed"
        about="Scriptversion.nt"
        craw="webcrawler.py"
        priv8="priv8.sh"
        cleanup="/tmp/evil"
        root3="/opt/metasploit/msf3/scripts/meterpreter/root3.rb"
      
       
      Last edit: pedro ubuntu 2015-07-25
  • moldy

    moldy - 2013-07-03

    Using up to date Kali, and Metasploit I'm having a problem installing Metasploit.

    Actually, I already have MSF insalled, however when I use your tool,it says I need to install it. There should be a way I could use my existing MSF, is there a way I can easily update the location? Same with Webcrawler.py.

    bug report

      [-] (Your choice?):9
      [*] [priv8.sh]: installation found...
      [x] [warning]: this module required Metasploit instaled to work...
      [+] more info here: http://l3w0nx.blogspot.pt/2012/03/install-metasploit-latest-linux.html
    


    Thinking I'll re-install it, I followed the directions within the script,
    and MSF is failing to install here:

      root@kali:~# sudo chmod + x metasploit-latest-linux-installer.run
      chmod: cannot access `x': No such file or directory
    

    Thank you...

     
    Last edit: pedro ubuntu 2013-11-25
    • pedro ubuntu

      pedro ubuntu - 2013-07-03



      if you are using kali-linux distro then 'metasploit' its allready installed by default (we dont need to install it again...)


      soluction

      download 'netool.sh' for kali-distro from here:
      netool.sh kali-distros
      video tutorial


      another soluction will be

      my metasploit install its on version "4-4.0" so my tool will point
      to that directory in search of MSF, a simple fix will be replace the path of 'metasploit' current install in 'priv8.sh' and 'netool.sh' script.

      [edit 'netool.sh' and replace the follow line]

        find4="/opt/metasploit-4.4.0"
      
        for:
      
        find4="/opt/metasploit"
      


      [edit 'priv8.sh' and replace the follow line]

        find="/opt/metasploit-4.4.0"
      
        for:
      
        find="/opt/metasploit"
      


      final notes

      'sudo' its to run a command as 'root' user, in kali-distros we are 'root' users by default (no need for sudo), and its 'chmod +x' and not 'chmod + x'...

      so the rigth command it will be:
      'chmod +x metasploit-latest-linux-installer.run'
      and then './metasploit-latest-linux-installer.run'
      (but we dont need to install the metasploit again...)


       
      Last edit: pedro ubuntu 2015-07-25
  • pedro ubuntu

    pedro ubuntu - 2013-09-17

    [Anggriyanto Pangaribuan]

    bug report

      kali linux has been up date for ettercap framework,
      (etter.dns its not in "/usr/share/ettercap" anymore)...
    
     
    Last edit: pedro ubuntu 2013-10-22
    • pedro ubuntu

      pedro ubuntu - 2013-09-17

      soluction

      [edit 'netool.sh' and replace the follow line]

        confD="/usr/share/ettercap/etter.dns"
      
        for:
      
        confD="etc/ettercap/etter.dns"
      


      [edit 'priv8.sh' and replace the follow line]

        confD="/usr/share/ettercap/etter.dns"
      
        for:
      
        confD="etc/ettercap/etter.dns"
      
       
      Last edit: pedro ubuntu 2013-11-25
  • Antonio Jesús

    Antonio Jesús - 2013-09-28

    Hello,

    iam using netool.sh V3.3 for KALI-LINUX distro
    in the module 9 [rootsector exploits] / 4,5,6 [clone website],
    metasploit-framework displays the following error:

    bug report

      [09/29/2013 00:15:44] [e(0)] core:
    

    /opt/metasploit/apps/pro/msf3/modules/post/windows/manage/portproxy.rb failed to load due to the following error:
    NameError
    uninitialized constant Msf::Post::Windows
    Call stack:
    /opt/metasploit/apps/pro/msf3/modules/post/windows/manage/portproxy.rb:10:in <class:Metasploit3>' /opt/metasploit/apps/pro/msf3/modules/post/windows/$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:54:in module_eval' /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.r$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:147:in block in load_module' /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loa$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:553:in namespace_module_transaction' /opt/metasploit/apps/pro/msf3/lib/msf/core/mod$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:271:in block in load_modules' /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/lo$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:60:in each' /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/director$
    /opt/metasploit/apps/pro/msf3/lib/rex/file.rb:127:in block in find' /opt/metasploit/apps/pro/msf3/lib/rex/file.rb:126:incatch'
    /opt/metasploit/apps/pro/msf3/lib/rex/file.rb:126:in find' /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:45:inblock in each_$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:29:in foreach' /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/direc$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:264:in load_modules' /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/load$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/loading.rb:116:in each' /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/loading.r$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/module_paths.rb:56:in block in add_module_path' /opt/metasploit/apps/pro/msf3/lib/msf/core/$
    /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/module_paths.rb:55:in add_module_path' /opt/metasploit/apps/pro/msf3/lib/msf/base/simple/fr$
    /opt/metasploit/apps/pro/msf3/msfcli:298:in init_modules' /opt/metasploit/apps/pro/msf3/msfcli:535:inrun!'
    /opt/metasploit/apps/pro/msf3/msfcli:557:in `'

    and metasploit fail/crash .... thanks

     
    Last edit: pedro ubuntu 2013-11-25
    • pedro ubuntu

      pedro ubuntu - 2013-10-09


      question:

      this bug only happens in [rootsector] modules 4,5,6
      (did the other modules in r00tsect0r works fine ???)

      final notes

      for your bug report i belive that the 'metasploit'
      installation in your KALI-LINUX its corrupted...
      (can you use msfconsole on your PC ???)

        my tool "r00tsect0r module" needs the "metasploit",
        "apache2" and "ettercap" installed to work, so if you
        have an error in any of this frameworks then
        my tool wont work.
      


      i belive that if your have the 'metasploit' corrupted
      the better soluction will bee installing again the KALI-LINUX
      distro (metasploit its allready installed by default)..
      and then my tool will work...

       
      Last edit: pedro ubuntu 2013-11-25
  • pedro ubuntu

    pedro ubuntu - 2013-10-22

    [ Sem Anony ]

    iam using netool.sh V3.3 for ubuntu distro
    the module 'priv8.sh' displays the following error:

    bug report

      [-] (Your choice?):9
      [*] [priv8.sh]: installation found...
      [x] [warning]: this module required Metasploit instaled to work...
      [+] more info here: http://l3w0nx.blogspot.pt/2012/03/install-metasploit-latest-linux.html
    
     
    Last edit: pedro ubuntu 2013-10-22
    • pedro ubuntu

      pedro ubuntu - 2014-03-23

      soluction:

      [opensource folder as to be installed in]

        ubuntu = /home/username/opensource
        kali = /root/opensource
      

      (if the tool as not installed in the rigth path then it will give errors)


      my metasploit install its on version "4-4.0" so my tool will point
      to that directory in search of MSF, a simple fix will be replace the path of 'metasploit' current install in 'priv8.sh' and 'netool.sh' script.

      [edit 'netool.sh' and replace the follow line]

        find4="/opt/metasploit-4.4.0"
      
        for:
      
        find4="/opt/metasploit"
      

      [edit 'priv8.sh' and replace the follow line]

        find="/opt/metasploit-4.4.0"
      
        for:
      
        find="/opt/metasploit"
      

      .

       
  • Anonymous - 2014-03-11

    bug report

      [-] (Your choice?):9
      ./netool.sh: 2524: cd: can't cd to /root/opensource
      [*] [priv8.sh]: installation found...
      ./netool.sh: 2528: cd: can't cd to /root/opensource/modules
    
     
    Last edit: pedro ubuntu 2014-03-23
    • pedro ubuntu

      pedro ubuntu - 2014-03-23

      soluction

      my tool dont use 'absoluct paths' to work, so it as to be installed on the rigth location to work proper, and your bug report shows that my tool its not installed in the rigth path, or that you have downloaded the wrong version of my tool for you OS.


      Download netool.sh for UBUNTU

        "install path in linux-ubuntu":
        unpack "opensource.tar.gz" under "/home/username" folder
        example: (home/username/opensource)
      



      Download netool.sh for KALI

        "install path in kali-linux":
        unpack "opensource[kali].tar.gz" under "/root" folder
        example: (/root/opensource)
      


      another soluction will be:

      edit the file "netool.sh" search for 'Path to instalations and variaveis do script' and then replace the paths for the rigth ones depending of your operative system configuration.

        find="/usr/share/nmap"
        find2="/usr/share/ettercap"
        find3="/usr/share/macchanger"
        find4="/opt/metasploit"
        confE="/etc/etter.conf"
        confD="/usr/share/ettercap/etter.dns"
        confP="/usr/share/ettercap/etter.services"
        confW="/usr/share/doc/driftnet"
        confSSL="installed"
        about="Scriptversion.nt"
        craw="webcrawler.py"
        priv8="modules/priv8.sh"
        cleanup="/tmp/evil"
        myaux="/usr/share/metasploit-framework/modules/auxiliary/analyze"
        root3="/opt/metasploit/apps/pro/scripts/meterpreter/root3.rb"
      


      edit the file "priv8.sh" search for 'path to frameworks installed' and then replace the paths for the rigth ones depending of your operative system configuration.

        priv8="priv8"
        cleanup="/tmp/evil"
        confD="/usr/share/ettercap/etter.dns"
        find="/opt/metasploit"
        apache="/var/www"
      


       
  • pedro ubuntu

    pedro ubuntu - 2014-06-14

    [BUG report - thantserpelis]

    actually i found an error so i thought to tell u using the sslstrip
    doesnt work probably the setup.py has an error this is what i got error:

      file '/root/opensource/sslstrip-0.9/sslstrip/sslstrip' does not exist
      [x] {sslstrip.py}:installed... RESTARTING:{netool.sh}
    
     
    Last edit: pedro ubuntu 2014-06-14
  • pedro ubuntu

    pedro ubuntu - 2014-06-14

    soluction

    hello, ive try to re-install the toolkit again on my ubuntu
    to repair the bug, but i didnt find any bug on it, since in my installation
    it works perfect (sslstrip module)...

    questions

    1 - do you have python installed on your OS?
    2 - do you have give root permitions for all files.py?

      cd opensource/ssslstrip-0.9 && chmod +x *.py
    

    my tool in the first run (sslstrip module) will search in the folder "opensource/sslstrip-0.9" for the file "installed"

    if it dosent find the file it starts installing sslstrip
    using "setup.py" file, after sslstrip installed you will see
    "installed" file and "build" folder...

    so check in "opensource/sslstrip-0.9" if "build" folder exists,
    and if "installed" file exists <-- this meens that the sslstrip as installed proper...

    check here the screenshots
    https://db.tt/15ZcXXfy
    https://db.tt/NmKDfGeC

     
    Last edit: pedro ubuntu 2014-06-14
  • Anonymous - 2014-08-04

    Incorrect number of token (///) in TARGET !!

    cd opensource/netool.sh

    driftnet -i $interface -d ~/opensource/netool-capture & ettercap -T -Q -i $interface -M arp //$targ/ /$rou//

    OK :)

     
    • pedro ubuntu

      pedro ubuntu - 2014-08-04



      taken from ettercap maling list webpage:
      http://sourceforge.net/.../mailman/ettercap-betatesting/

      As per the man pages, it needs an extra / in the target selection because of the IPv6 capability. we have been using ettercap agains IPV4 and the new protocol IPV6 seems to work diferent,

      how to fix it

      edit 'netoo.sh' and 'priv8.sh' and insert an extra / in the target selection

        ettercap -T -M arp /// ///
        OR
        ettercap -T -M arp //$target/ /$router//
        should work...
      
       
      Last edit: pedro ubuntu 2015-09-28
  • Anonymous - 2015-02-19

    This is On kali

    [*] Initializing modules...
    [-] Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
    could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?

    APPLETNAME => microsoft
    TARGET => 0
    PAYLOAD => java/meterpreter/reverse_tcp
    LHOST => 192.168.1.106
    URIPATH => /support
    [*] Exploit running as background job.

     
    • pedro ubuntu

      pedro ubuntu - 2015-02-20


      hello hax0r, But that error display its not my toolkit (netool.sh t00lkit) fault, this is a metasploit internal error or you are not connected to network, but i belive that possible causes are:


      1º - you did not have started the postgres service on your machine
      (90% sure of that)

        service postgresql start
      


      2º - You can verify that PostgreSQL is running by checking the output
      of [ ss -ant | egrep "5432" ] and making sure that port 5432 is listening.

        State Recv-Q Send-Q Local Address:Port Peer Address:Port
        LISTEN 0 128 127.0.0.1:5432 *:*
        LISTEN 0 128 ::1:5432 :::*
      


      3º - Start the Kali Metasploit Service

        service metasploit start
      


      4º - check if everything its OK...
      Now that the PostgreSQL an Metasploit services are running,
      you can launch msfconsole and verify database connectivity
      with the db_status command as shown below.

        msfconsole
      
        msf > db_status
        [*] postgresql connected to msf3
        msf >
      



      P.S: this is not a bug on my toolkit


       
      Last edit: pedro ubuntu 2015-02-20
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2015-07-24
    1. netool[kali].tar.gz
    2. While using option 13 in netool.sh with newest kali in vm I get the following:

    bug report

    Unhandled Error
    Traceback (most recent call last):
    File "./sslstrip.py", line 105, in main
    reactor.run()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1169, in run
    self.mainLoop()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1181, in mainLoop
    self.doIteration(t)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/pollreactor.py", line 167, in doPoll
    log.callWithLogger(selectable, _drdw, selectable, fd, event)
    --- <exception caught="" here=""> ---
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
    return self.currentContext().callWithContext(ctx, func,
    args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
    return func(*args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 599, in _doReadOrWrite
    self._disconnectSelectable(selectable, why, inRead)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 263, in _disconnectSelectable
    selectable.connectionLost(f)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 433, in connectionLost
    Connection.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 277, in connectionLost
    protocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 455, in connectionLost
    self.handleResponseEnd()
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 119, in handleResponseEnd
    HTTPClient.handleResponseEnd(self)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 466, in handleResponseEnd
    self.handleResponse(b)
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 133, in handleResponse
    self.client.write(data)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 898, in write
    raise RuntimeError('Request.write called on a request after '
    exceptions.RuntimeError: Request.write called on a request after Request.finish was called.
    Unhandled Error
    Traceback (most recent call last):
    File "./sslstrip.py", line 105, in main
    reactor.run()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1169, in run
    self.mainLoop()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1181, in mainLoop
    self.doIteration(t)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/pollreactor.py", line 167, in doPoll
    log.callWithLogger(selectable, _drdw, selectable, fd, event)
    --- <exception caught="" here=""> ---
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
    return self.currentContext().callWithContext(ctx, func,
    args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
    return func(*args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 599, in _doReadOrWrite
    self._disconnectSelectable(selectable, why, inRead)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 263, in _disconnectSelectable
    selectable.connectionLost(f)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 433, in connectionLost
    Connection.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 277, in connectionLost
    protocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 455, in connectionLost
    self.handleResponseEnd()
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 119, in handleResponseEnd
    HTTPClient.handleResponseEnd(self)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 466, in handleResponseEnd
    self.handleResponse(b)
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 133, in handleResponse
    self.client.write(data)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 898, in write
    raise RuntimeError('Request.write called on a request after '
    exceptions.RuntimeError: Request.write called on a request after Request.finish was called.
    Unhandled Error
    Traceback (most recent call last):
    File "./sslstrip.py", line 105, in main
    reactor.run()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1169, in run
    self.mainLoop()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1181, in mainLoop
    self.doIteration(t)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/pollreactor.py", line 167, in doPoll
    log.callWithLogger(selectable, _drdw, selectable, fd, event)
    --- <exception caught="" here=""> ---
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
    return self.currentContext().callWithContext(ctx, func,
    args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
    return func(*args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 599, in _doReadOrWrite
    self._disconnectSelectable(selectable, why, inRead)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 263, in _disconnectSelectable
    selectable.connectionLost(f)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 433, in connectionLost
    Connection.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 277, in connectionLost
    protocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 455, in connectionLost
    self.handleResponseEnd()
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 119, in handleResponseEnd
    HTTPClient.handleResponseEnd(self)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 466, in handleResponseEnd
    self.handleResponse(b)
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 133, in handleResponse
    self.client.write(data)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 898, in write
    raise RuntimeError('Request.write called on a request after '
    exceptions.RuntimeError: Request.write called on a request after Request.finish was called.
    Unhandled Error
    Traceback (most recent call last):
    File "./sslstrip.py", line 105, in main
    reactor.run()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1169, in run
    self.mainLoop()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1181, in mainLoop
    self.doIteration(t)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/pollreactor.py", line 167, in doPoll
    log.callWithLogger(selectable, _drdw, selectable, fd, event)
    --- <exception caught="" here=""> ---
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
    return self.currentContext().callWithContext(ctx, func,
    args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
    return func(*args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 599, in _doReadOrWrite
    self._disconnectSelectable(selectable, why, inRead)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 263, in _disconnectSelectable
    selectable.connectionLost(f)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 433, in connectionLost
    Connection.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 277, in connectionLost
    protocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 455, in connectionLost
    self.handleResponseEnd()
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 119, in handleResponseEnd
    HTTPClient.handleResponseEnd(self)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 466, in handleResponseEnd
    self.handleResponse(b)
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 133, in handleResponse
    self.client.write(data)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 898, in write
    raise RuntimeError('Request.write called on a request after '
    exceptions.RuntimeError: Request.write called on a request after Request.finish was called.
    Unhandled Error
    Traceback (most recent call last):
    File "./sslstrip.py", line 105, in main
    reactor.run()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1169, in run
    self.mainLoop()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1181, in mainLoop
    self.doIteration(t)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/pollreactor.py", line 167, in doPoll
    log.callWithLogger(selectable, _drdw, selectable, fd, event)
    --- <exception caught="" here=""> ---
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
    return self.currentContext().callWithContext(ctx, func,
    args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
    return func(*args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 599, in _doReadOrWrite
    self._disconnectSelectable(selectable, why, inRead)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 263, in _disconnectSelectable
    selectable.connectionLost(f)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 433, in connectionLost
    Connection.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 277, in connectionLost
    protocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 455, in connectionLost
    self.handleResponseEnd()
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 119, in handleResponseEnd
    HTTPClient.handleResponseEnd(self)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 466, in handleResponseEnd
    self.handleResponse(b)
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 133, in handleResponse
    self.client.write(data)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 898, in write
    raise RuntimeError('Request.write called on a request after '
    exceptions.RuntimeError: Request.write called on a request after Request.finish was called.
    Unhandled Error
    Traceback (most recent call last):
    File "./sslstrip.py", line 105, in main
    reactor.run()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1169, in run
    self.mainLoop()
    File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1181, in mainLoop
    self.doIteration(t)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/pollreactor.py", line 167, in doPoll
    log.callWithLogger(selectable, _drdw, selectable, fd, event)
    --- <exception caught="" here=""> ---
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
    return self.currentContext().callWithContext(ctx, func,
    args, kw)
    File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
    return func(*args,
    kw)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 599, in _doReadOrWrite
    self._disconnectSelectable(selectable, why, inRead)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 260, in _disconnectSelectable
    selectable.readConnectionLost(f)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 257, in readConnectionLost
    self.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 433, in connectionLost
    Connection.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 277, in connectionLost
    protocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/protocols/tls.py", line 460, in connectionLost
    ProtocolWrapper.connectionLost(self, reason)
    File "/usr/lib/python2.7/dist-packages/twisted/protocols/policies.py", line 123, in connectionLost
    self.wrappedProtocol.connectionLost(reason)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 455, in connectionLost
    self.handleResponseEnd()
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 119, in handleResponseEnd
    HTTPClient.handleResponseEnd(self)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 466, in handleResponseEnd
    self.handleResponse(b)
    File "/root/opensource/sslstrip-0.9/sslstrip/ServerConnection.py", line 133, in handleResponse
    self.client.write(data)
    File "/usr/lib/python2.7/dist-packages/twisted/web/http.py", line 898, in write
    raise RuntimeError('Request.write called on a request after '
    exceptions.RuntimeError: Request.write called on a request after Request.finish was called.

     
    Last edit: pedro ubuntu 2015-07-25
    • pedro ubuntu

      pedro ubuntu - 2015-07-24



      Thanks for the bug report...

      But i belive that this bug its on SSLstrip 0.9 or your kali distro installation, and not on my toolkit, after reading your report i went try the sslstrip module "in my toolkit" and it works fine inside my ubuntu distro like the above screenshots shows:

      https://db.tt/nvTlMgoB
      https://db.tt/NTTfkbrG

      possible solutions

      The first time sslstrip module runs it will install sslstrip dependencies and close the toolkit "for the changes take effect".

      1 - did you try to run again the sslstrip module?
      2 - did you have config etter.conf file to run ettercap as root [ UID 0 GID 0 ]?
      3 - did you have config etter.conf file to use SSL disectors "redir_command_on" (un-comment the field: if you use iptables)?

       
      Last edit: pedro ubuntu 2015-07-25
1 2 > >> (Page 1 of 2)


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks