Using Netgen 4.9.x with NGSolve 4.9.5

Help
2009-03-05
2013-05-27
  • Nobody/Anonymous

    Hi, I would like to run Netgen 4.9.x with NGSolve 4.9.5 for solving, but could not find any documentation on this (I may have missed something too).

    I had successfully compiled these packages (versions 4.9.5) individually on my debian linux platform, and both ran well separately.

    Thanks,
    Kin

     
    • Joachim Schoeberl

      Hi Kin,

      you are right, the use of NGSolve 4.9.x together with Netgen 4.9.x is not documented, yet.

      It works like this:

      Compile and install Netgen
      Compile and install NGSolve

      Run Netgen, and it should load NGSolve as shared library.
      You should get the "Solve" menu entry.

      If it does not work:
      Please have a look to the last few lines of the script file 'ng.tcl'
      Here, it tries to load the dynamic library 'libngsolve.so'
      If you comment in the next few lines, you will get the error message why it failed.

      Best,
      Joachim

       
    • Nobody/Anonymous

      Hi, Joachim.  It ran, using some of the old tutorial files as tests (but not found in my recently downloaded package).  Thanks very much for your pointers.

      Notes for other users:

      In running "configure" for NGSolve in Linux, I had used the options:
      --prefix=$HOME/UserDir/Tmp/NGSolve     (for dumping the compiled code into my test directory)
      --with-netgen=/usr/include/tcl8.4\ \-I$HOME/UserDir/Tmp/Netgen    (this is to include my Tcl 8.4 library and my compiled Netgen files which were not in standard path locations)

      Then I looked for the ng.tcl file and modified it, to specify the path of the dynamic library, as described by Joachim.

      These are just quick steps for making NGSolve to run with Netgen.  However, there may be better ways of doing all these.

      Regards,
      Kin

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks