SourceForge has been redesigned. Learn more.
Close

Netgen can't read a CSG file when use command line

Help
wangjian
2013-09-16
2013-09-16
  • wangjian

    wangjian - 2013-09-16

    i can load a cube.geo file and mesh successufully in GUI.But it can't work when i use netgen in command line .i can test NETGEN -help and so on .when I test netgen cube.geo ,it show the file should start with the'algebraic3d' .I can make sure the file format is right.My version is 5.0_x64.anybody can help me out ?thanks

     
  • wangjian

    wangjian - 2013-09-16

    C:\Users\wangjian>netgen cube.geo
    NETGEN-5.0.0
    Developed by Joachim Schoeberl at
    2010-xxxx Vienna University of Technology
    2006-2010 RWTH Aachen University
    1996-2006 Johannes Kepler University Linz
    optfile ./ng.opt does not exist - using default values
    Load CSG geometry file cube.geo
    Problem with input file:
    geo-file should start with 'algebraic3d'
    NGSolve-5.0.0
    Using Lapack
    Including sparse direct solver Pardiso
    Running OpenMP - parallel using 4 thread(s)
    (number of threads can be changed by setting OMP_NUM_THREADS)
    loading demo-application
    Init demoapp

     
    Last edit: wangjian 2013-09-16
  • wangjian

    wangjian - 2013-09-16

    optfile ./ng.opt does not exist - using default values
    Load STL geometry file part1.stl
    NGSolve-5.0.0
    Using Lapack
    Including sparse direct solver Pardiso
    Running OpenMP - parallel using 4 thread(s)
    (number of threads can be changed by setting OMP_NUM_THREADS)
    loading demo-application
    Init demoapp

    when I use netgen part1.stl,it seems no error,but the GUI show nothing

     

Log in to post a comment.