Building netgen with OCC 6.5.3

  • Niels Linnemann

    Niels Linnemann - 2012-07-11


    Trying to build netgen with OCC 6.5.3 gives me the following error during build

    libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -I../../libsrc/include -DOCCGEOMETRY -I/share/apps/usr//inc -I/usr/include/opencascade -D_OCC64 -DHAVE_IOSTREAM -DHAVE_LIMITS -DHAVE_LIMITS_H -DHAVE_IOMANIP -I/usr/include -g -O2 -MT occconstruction.lo -MD -MP -MF .deps/occconstruction.Tpo -c occconstruction.cpp  -fPIC -DPIC -o .libs/occconstruction.o
    Partition_Spliter.cxx: In function 'void findEqual(const TopTools_ListOfShape&, const TopTools_ListOfShape&, Standard_Boolean, TopTools_DataMapOfShapeListOfShape&, TopTools_MapOfShape&)':
    Partition_Spliter.cxx:1172: error: 'class Extrema_ExtPC' has no member named 'Value'
    Partition_Loop.cxx: In function 'Standard_Boolean SelectEdge(const TopoDS_Face&, const TopoDS_Edge&, const TopoDS_Vertex&, TopoDS_Edge&, TopTools_ListOfShape&)':
    Partition_Loop.cxx:181: error: 'PI' was not declared in this scope
    make[3]: *** [Partition_Loop.lo] Error 1
    make[3]: *** Waiting for unfinished jobs....
    make[3]: *** [Partition_Spliter.lo] Error 1
    Partition_Loop2d.cxx: In function 'Standard_Boolean SelectEdge(const BRepAdaptor_Surface&, const TopoDS_Edge&, const TopoDS_Vertex&, TopoDS_Edge&, const TopTools_ListOfShape&)':
    Partition_Loop2d.cxx:213: error: 'PI' was not declared in this scope
    make[3]: *** [Partition_Loop2d.lo] Error 1
    Partition_Inter3d.cxx: In function 'void PutInBounds(const TopoDS_Face&, const TopoDS_Edge&, Handle_Geom2d_Curve&)':
    Partition_Inter3d.cxx:246: error: 'class Extrema_ExtPS' has no member named 'Value'
    make[3]: *** [Partition_Inter3d.lo] Error 1
    mv -f .deps/Partition_Loop3d.Tpo .deps/Partition_Loop3d.Plo
    mv -f .deps/occconstruction.Tpo .deps/occconstruction.Plo
    mv -f .deps/Partition_Inter2d.Tpo .deps/Partition_Inter2d.Plo
    mv -f .deps/occgenmesh.Tpo .deps/occgenmesh.Plo
    make[3]: Leaving directory `/share/apps/build/netgen-mesher/netgen/libsrc/occ'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/share/apps/build/netgen-mesher/netgen/libsrc'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/share/apps/build/netgen-mesher/netgen'
    make: *** [all] Error 2

    Also tried with OCC 6.3.0 but that was a different error.

    Any advice on the correct version?

  • Niels Linnemann

    Niels Linnemann - 2012-07-17

    Thx it helped. I went through the files manually and it seems in 4.9.14-svn the fixes are already present but it is a mix of 6.3 and 6.5 support. So after making it all work with 6.5 I got a little further, it although failed in two files complaining that PI was an undeclared variable to i added a const double scalar = 3.14……..etc at the top of those two files and now it works just fine.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks