Hello this is my first post.

I am currently trying out netdisco 2 as we are currently netdisco 1.x users.
It seems OK at discovering cisco equipment, but when I try to discover juniper ex2200 switches I am getting the following problem:

[netdisco@melkor ~]$ ~/bin/netdisco-do -D discover -d 10.0.192.130
[15446]  info @0.000015> discover: started at Wed Apr  2 14:05:08 2014
The pass option is deprecated. Use password instead. at /home/netdisco/perl5/lib/perl5/Dancer/Plugin/DBIC.pm line 40.
[15446] debug @0.214281> [10.0.192.130] try_connect with ver: 2, class: SNMP::Info::Layer3::Juniper, comm: public
[15446] debug @2.205533>  [10.0.192.130] device - aliased as 10.0.192.130
[15446] debug @2.205763>  resolving 1 aliases with max 50 outstanding requests
[15446] debug @2.368730>  [10.0.192.130] device - removed 1 aliases
[15446] debug @2.375727>  [10.0.192.130] device - added 1 new aliases
[15446] debug @8.959597>  [10.0.192.130] interfaces - removed 28 interfaces
[15446] debug @8.974682>  [10.0.192.130] interfaces - added 28 new interfaces
[15446] debug @9.508763>  [10.0.192.130] vlans - removed 0 device VLANs
[15446]  info @9.521709> discover: finished at Wed Apr  2 14:05:18 2014
[15446]  info @9.521867> discover: status error: error running job: DBIx::Class::Storage::DBI::_dbh_execute_for_fetch(): execute_for_fetch() aborted with 'ERROR:  duplicate key value violates unique constraint "device_vlan_pkey"' at populate slice:
{
  description => "default",
  ip => "10.0.192.130",
  last_discover => \"now()",
  vlan => 0
} at /home/netdisco/perl5/lib/perl5/App/Netdisco/Core/Discover.pm line 457

Also the devices are showing up on the web app, but they are not showing as having anything attached to their ports.
I have noticed that the UI seems alot faster than version 1.x when displaying information for the juniper switches.

Can anyone help?

Thanks

Gary Lloyd
----------------------------------
IT Services
Keele University
-----------------------------------