I’ve tried again this evening with the 3.1.5 release.  Unfortunately, afpd is still panicking with signal 11 when I initiate a search from either a 10.6 or 10.9 client:

Aug 12 23:19:04.637864 afpd[4582] {fault.c:123} (severe:Default): ===============================================================
Aug 12 23:19:04.637939 afpd[4582] {fault.c:124} (severe:Default): INTERNAL ERROR: Signal 11 in pid 4582 (3.1.5)
Aug 12 23:19:04.637961 afpd[4582] {fault.c:125} (severe:Default): ===============================================================
Aug 12 23:19:04.638382 afpd[4582] {fault.c:96} (severe:Default): PANIC: internal error
Aug 12 23:19:04.638415 afpd[4582] {fault.c:97} (severe:Default): BACKTRACE: 8 stack frames:
Aug 12 23:19:04.638453 afpd[4582] {fault.c:103} (severe:Default):  #0 /usr/local/lib/libatalk.so.16(netatalk_panic+0x24) [0x7fead5b5ff04]
Aug 12 23:19:04.638524 afpd[4582] {fault.c:103} (severe:Default):  #1 /usr/local/lib/libatalk.so.16(+0x39038) [0x7fead5b60038]
Aug 12 23:19:04.638584 afpd[4582] {fault.c:103} (severe:Default):  #2 /lib/x86_64-linux-gnu/libc.so.6(+0x37000) [0x7fead4682000]
Aug 12 23:19:04.638626 afpd[4582] {fault.c:103} (severe:Default):  #3 /usr/local/sbin/afpd(afp_spotlight_rpc+0xc18) [0x4321a8]
Aug 12 23:19:04.638664 afpd[4582] {fault.c:103} (severe:Default):  #4 /usr/local/sbin/afpd(afp_over_dsi+0x511) [0x40e071]
Aug 12 23:19:04.638694 afpd[4582] {fault.c:103} (severe:Default):  #5 /usr/local/sbin/afpd(main+0xb80) [0x40c450]
Aug 12 23:19:04.638726 afpd[4582] {fault.c:103} (severe:Default):  #6 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7fead466cec5]
Aug 12 23:19:04.638749 afpd[4582] {fault.c:103} (severe:Default):  #7 /usr/local/sbin/afpd() [0x40c588]
Aug 12 23:19:04.840841 afpd[3802] {main.c:154} (info:AFPDaemon): child[4582]: killed by signal 6
Aug 12 23:19:04.876379 afpd[6745] {dsi_tcp.c:241} (info:DSI): AFP/TCP session from 10.11.1.154:52402
Aug 12 23:19:04.878441 afpd[6745] {uams_dhx2_pam.c:329} (info:UAMS): DHX2 login: t.cullen
Aug 12 23:19:04.936820 afpd[6745] {uams_dhx2_pam.c:214} (info:UAMS): PAM DHX2: PAM Success
Aug 12 23:19:05.117883 afpd[6745] {uams_dhx2_pam.c:709} (info:UAMS): DHX2: PAM Auth OK!
Aug 12 23:19:05.118025 afpd[6745] {auth.c:236} (note:AFPDaemon): Login by t.cullen (AFP3.3)
Aug 12 23:19:05.119238 afpd[6745] {auth.c:567} (note:AFPDaemon): afp_disconnect: trying primary reconnect
Aug 12 23:19:05.119440 afpd[3802] {server_child.c:233} (note:Default): Reconnect: no child[4582]
Aug 12 23:19:10.119439 afpd[6745] {auth.c:600} (error:AFPDaemon): afp_disconnect: primary reconnect failed
Aug 12 23:19:10.136260 afpd[6745] {spotlight.c:1276} (info:Spotlight): Initializing Spotlight
Aug 12 23:19:10.137087 afpd[6745] {spotlight.c:1394} (error:Default): sl_rpc_fetchQueryResultsForContext(obj, query, reply, vol) failed: Resource temporarily unavailable
Aug 12 23:19:10.179011 afpd[6745] {quota.c:648} (info:AFPDaemon): getquota: special /main-storage/Office fails
Aug 12 23:19:20.138468 afpd[6745] {spotlight.c:588} (info:Spotlight): connected to Tracker
Aug 12 23:19:20.443863 afpd[6745] {fault.c:123} (severe:Default): ===============================================================
Aug 12 23:19:20.443961 afpd[6745] {fault.c:124} (severe:Default): INTERNAL ERROR: Signal 11 in pid 6745 (3.1.5)
Aug 12 23:19:20.444072 afpd[6745] {fault.c:125} (severe:Default): ===============================================================
Aug 12 23:19:20.444936 afpd[6745] {fault.c:96} (severe:Default): PANIC: internal error
Aug 12 23:19:20.445012 afpd[6745] {fault.c:97} (severe:Default): BACKTRACE: 8 stack frames:
Aug 12 23:19:20.445123 afpd[6745] {fault.c:103} (severe:Default):  #0 /usr/local/lib/libatalk.so.16(netatalk_panic+0x24) [0x7fead5b5ff04]
Aug 12 23:19:20.445215 afpd[6745] {fault.c:103} (severe:Default):  #1 /usr/local/lib/libatalk.so.16(+0x39038) [0x7fead5b60038]
Aug 12 23:19:20.445281 afpd[6745] {fault.c:103} (severe:Default):  #2 /lib/x86_64-linux-gnu/libc.so.6(+0x37000) [0x7fead4682000]
Aug 12 23:19:20.445369 afpd[6745] {fault.c:103} (severe:Default):  #3 /usr/local/sbin/afpd(afp_spotlight_rpc+0xc18) [0x4321a8]
Aug 12 23:19:20.445433 afpd[6745] {fault.c:103} (severe:Default):  #4 /usr/local/sbin/afpd(afp_over_dsi+0x511) [0x40e071]
Aug 12 23:19:20.445541 afpd[6745] {fault.c:103} (severe:Default):  #5 /usr/local/sbin/afpd(main+0xb80) [0x40c450]
Aug 12 23:19:20.445621 afpd[6745] {fault.c:103} (severe:Default):  #6 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7fead466cec5]
Aug 12 23:19:20.445706 afpd[6745] {fault.c:103} (severe:Default):  #7 /usr/local/sbin/afpd() [0x40c588]
Aug 12 23:19:20.623415 afpd[3802] {main.c:154} (info:AFPDaemon): child[6745]: killed by signal 6



As you can see, it will immediately reconnect, so the client doesn’t see the failure, other than a bit of a pause.

I’ve tried the following, but they have not had any effect:



The panic does not seem to be consistent.  If I only index very small volumes, then it’s fine.  But as soon as the index gets to some certain level of complexity, the afpd process panics.  I don’t know just what this level might be.  But I know if I search wile tracker is still processing:

Store:
12 Aug 2014, 23:29:47:  ✓     Store                 - Idle 

Miners:
12 Aug 2014, 23:29:48:   42%  File System           - Processing… 45m 01s remaining
12 Aug 2014, 23:29:48:  ✓     Applications          - Idle 


Then the search will return some results and there’s no afpd panic.  But once it gets closer to finished (85% to completely finished), then the afpd panic happens.  I can’t say this conclusively, but it seems the panic is more likely  for searches that return a lot of results.


One last oddity:  10.6 and 10.9 clients return the same number of results for the same search on the same volume.  On 10.6 clients, the results that get returned are all broken aliases.  None of the folders show as folders.  None of the icons show any previews or quick-view.  Double-clicking on any of the search results just brings up the “This original item cannot be found” dialogue box.  

On 10.9 clients, results show up as expected, with previews, folders, quick-view, etc.


Hope this helps some. 
-Joe Rhodes




On Aug 12, 2014, at 8:33 AM, Ralph Böhme <rb@netafp.com> wrote:


Am 12.08.2014 um 14:12 schrieb Joe Rhodes <lists@joerhodes.com>:

I just tried the 3.1.5 release.  afpd is still crashing with Signal 11 as soon as I attempt to search the volume. (With either a 10.6 or a 10.9 client)  I’m running on Ubuntu 14.04.  Not sure if the fixes in the for this got rolled into the 3.1.5 or not though.  (From the e-mail thread "[Netatalk-admins] Signal 11 at the moment of logging in”.)

strange. Works for me and HAT tested it on several different Linux flavors, iirc including Ubuntu 14.04.

Cheerio!
-r