Hi All,
 
I found what was the problem.  Do not use "public" as community name for read-write access.  Use "private" instead.
 
Thanks everybody to your support!
 
Leo;

--- On Wed, 9/1/10, Leo Lin <hayashi_leo@yahoo.com> wrote:

From: Leo Lin <hayashi_leo@yahoo.com>
Subject: Re: Unable to Extend snmpd: There is not such variable name in this MIB
To: "Net-snmp-users" <net-snmp-users@lists.sourceforge.net>, "Mishustin Kirill" <mishustin@eltex.nsk.ru>
Cc: hayashi_leo@yahoo.com
Date: Wednesday, September 1, 2010, 1:54 PM

Hi Mishustin,
 
I've found why Net-SNMP shows the error :
 
"LLC-MIB: No such file or directory".
 
I found out that snmpconf() tool can load as many MIB files as you want, even though, it is the same MIB file.  So, the first time I loaded my LLC-MIB.txt it was ok, but the 2nd time, something was wrong.
 
the snmpconf() tool, does not tell you if the MIB file was loaded successfully or not.  So, when I type
 
snmptranslate -Tp -IR frequency,
it does find the LLC-MIB file (the one I loaded correctly), but also try to load the 2nd LLC-MIB file, the one has wrong path, so that when the error message appears, because I instructed the Net-SNMP to output the errors to stderr instead of a log file.
 
To fix this, I removed (rm) the snmp.conf and snmpd.conf file and re-created them with snmpconf() tool.
 
I tried to extend again the snmp agent with mib2c.  I re-created the header and source files for 'frequency' and 'step', and them re-compiled them using
 
./configure --with-mib-modules="frequency step"
 
somehow during the configure script, net-snmp tries to access the "module_tmp_header.h" file, which does not exist.
 
if I don't give the parameters --with-mib-modules, the script runs fine.
 
Is this normal?
 
Thanks!
 
Leo;

--- On Tue, 8/31/10, Mishustin Kirill <mishustin@eltex.nsk.ru> wrote:

From: Mishustin Kirill <mishustin@eltex.nsk.ru>
Subject: Re: Unable to Extend snmpd: There is not such variable name in this MIB
To: "Net-snmp-users" <net-snmp-users@lists.sourceforge.net>
Cc: "Leo Lin" <hayashi_leo@yahoo.com>
Date: Tuesday, August 31, 2010, 9:53 PM

01.09.2010 10:38, Leo Lin wrote:
Hi, thanks for replying
 
I got these result with /usr/local/sbin/snmpd -Dmib_init
 
No log handling enabled - using stderror logging
registered debug token mib_init, 1
Log handling defined - disabling stderr
 
I checked that the process is queued with ps().
 
I also tried
 
snmpget -v 1 -c public localhost sysDescr.0
 
with the following result:
 
LLC-MIB: No such file or directory
SNMPv2-MIB::sysDescr.0 = STRING: CYGWIN_NT-5.1
 
Thanks!
 
Leo;


And that's all? Initial output should end with "NET-SNMP version x.x.x". If you don't see that string - something is seriously wrong.
Post here how you launch configure script for net-snmp, I mean parameters for configure.
And this "LLC-MIB: No such file or directory" worries me. Try quering agent with numerical oid. ( 1.3.6.1.4.1.331.1.1.0 for frequency from your mib).

And please, don't mail me privately. Keep discussion on the list, so others can learn from it.