Newbie help

Help
2003-08-26
2013-05-15
  • Stephen Matthews

       Sorry if this is a lame question, but I thought I'd like to try your editor, but couldn't get it to work.  I am still very new to Linux, but trying to learn, so don't shoot me. 
       I am working on a Dell Dimension 8200, running Red Hat 9.0.  I pulled nedit-5.3-linux-x86.tar.Z and installed nedit and nc into /usr/local/bin, then moved to my user account and typed nedit, and got the following:

    ************************
    [matthewssw@me150-239 matthewssw]$ nedit
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    NEdit: Can't open display
    ************************

    Do I have the wrong copy of nedit, or is this something simple.  Please let me know if you can.

    Tks
       Bootshine

     
    • H. Eismark

      H. Eismark - 2004-02-16

      I had this problem once; If you didn't log out of root, but just did su user, then I think this is what happened.

      So log root out in the terminal and user nedit.

      I think it has something to do with number of displays available.

       
    • Dr. Lothar Esser

      I think the previous post-er is right. You have to login as a regular user so that you kind of "own" the X session.
      Alternatively you can try  the command: xhost + 
      But be aware that this will allow anybody to connect to your xserver so this is only a temporary solution.
      L.

       
    • trmn8r

      trmn8r - 2006-04-21

      I use NEdit at work, and would like to install it on my PC at home. I am running with Solaris 10 on this machine. At work, they have Solaris 9.
      I am not able to get the downloaded executable to run on my machine at home, I have tried several different types that are available on the download page, all of them give me an error "unable to run nedit".
      Does anyone have any suggestions as to how to go about installing this on a machine running Solaris 10 where it will actually run?
      Thanks in advance.

       
      • Thorsten Haude

        Thorsten Haude - 2006-04-21

        Hi,

        the mailing list is usually a much better place to ask this kind of question. I suggest you move this thread there. (http://www.nedit.org/mail.php)

        Now about your problem: The version you should try is this:
        http://www.nedit.org/ftp/v5_5/executables/nedit-5.5-Solaris-sparc.tar.gz

        If that does not work, we would need more information. Please provide the output of 'nedit -V', the exact command you enter and the exact error message.

        Thorsten

         
    • trmn8r

      trmn8r - 2006-04-28

      I tried the "sparc.tar" executable, also tried two of the others (Linux and the other Solaris - all were unzipped/untarred of course), but still am not able to run Nedit.
      I also tried setting the permissions (rwx), that didn't help either.
      These are the error messages that I see:
      (ksh) nedit : cannot execute
      (tcsh) /nedit/nedit: Invalid argument
      (csh) /nedit/nedit: Invalid argument
      (bash) /nedit/nedit: Invalid argument

      from "root"
      #: nedit: cannot execute

      Not sure what to do now, any suggestions?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks