#517 strange scrolling bug?

release
closed-fixed
Program (402)
5
2007-08-04
2006-03-24
schloob
No

here's my version information:
Built on: Linux, Athlon, GNU C
Built at: Mar 23 2006, 18:33:02
With Motif: 2.2.3 [@(#)Motif Version 2.2.3]
Running Motif: 2.2 [unknown]
Server: Gentoo (The X.Org Foundation 6.8.2,
revision r6-0.1.13) 60802000
Visual: 32-bit TrueColor (ID 0x130)
Locale: C

so here's what happens: whenever i scroll up using the
mouse wheel or scrollbar (the page-up key works fine
usually), the screen bugs out and all i see is like 4
lines of text repeated over and over. if i use the
scrollbar, it's usually only one line of text repeated
on the screen. scrolling down works fine!

i've included four screenshots of what i mean.
normal.png : before i've scrolled
after_scrollup.png : after scrolling up with the mouse
wheel once
after_selectall.png : after i hit ctrl-a to select all
the text, seems to fix the problem - probably because
it forces a complete screen redraw?
uparrow.png : this was after i press the up arrow when
the cursor is at the top of the screen (therefore
making it scroll up). ctrl-a fixes this too.

this could possibly be a motif bug, because the same
thing happens in the help window that shows version
information. i haven't seen this behavior in any other
motif applications though, i'm trying a few out but i'm
not seeing anything. it might be the text widget that
nedit uses. i've tried both the statically linked
pre-compiled binaries and fresh compiled ones.

thanks

Discussion

  • schloob

    schloob - 2006-03-24

    pictures

     
    Attachments
  • schloob

    schloob - 2006-03-28
    • status: open --> wont-fix
     
  • Russ W. Knize

    Russ W. Knize - 2006-11-29

    Logged In: YES
    user_id=59461
    Originator: NO

    I am also seeing this exact issue now that I have upgraded my local machine to Ubuntu Edgy Eft. I used NEdit remotely on various SunOS and Linux servers. They are all using NEdit 5.5. I use a variety of old and new tools this way, but only NEdit has this problem.

    Since the issue started after upgrading my local machine, it seems to be some kind of X-related problem, possibly between Motif and X.

     
  • Eddy De Greef

    Eddy De Greef - 2006-11-29

    Logged In: YES
    user_id=73597
    Originator: NO

    This is probably caused by the ARGB visuals in the newer X.Org versions (which Motif cannot handle).

    Please try the following:

    XLIB_SKIP_ARGB_VISUALS=1 nedit

    and tell us whether the problem persists.

    The next version of NEdit will set this variable automatically, BTW.

     
  • Eddy De Greef

    Eddy De Greef - 2006-11-29
    • status: wont-fix --> pending
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed
     
  • Nick Sutterer

    Nick Sutterer - 2007-01-18

    Logged In: YES
    user_id=410000
    Originator: NO

    i also encountered this bug on edgy (amd64), but after compiling from current cvs sources the bug seems to be gone. :-)

     
  • Nobody/Anonymous

    Logged In: NO

    XLIB_SKIP_ARGB_VISUALS=1 has no effect on this issue (it does fix the crash at startup, though). I tried 5.4 and 5.5 on the remote Sun boxen, just for the heck of it, but they behave the same. I have no problems when I use Dapper Drake, locally. One thing to add is that I am also using the AMD64 port of Edgy.

    It's REALLY annoying and I am starting to look for alternative editors.

     
  • Scott Tringali

    Scott Tringali - 2007-03-12

    Logged In: YES
    user_id=11321
    Originator: NO

    Hi nobody (rkinze). If you would help us with some reproducer information, we would have a chance at trying to reproduce it. As such, we have no idea what environment you are running with. You may be running into a separate problem.

    In particular, we would need to know the version info from the remote Sun boxes, and an OS release would really help.

    We really can't fix it until we reproduce your problem unless we start debugging by email.

     
  • Thorsten Haude

    Thorsten Haude - 2007-03-18

    Logged In: YES
    user_id=119143
    Originator: NO

    (Seems to be at least partly independent of XLIB_SKIP_ARGB_VISUALS.)

     
  • Thorsten Haude

    Thorsten Haude - 2007-03-18
    • status: closed --> open
     
  • Nobody/Anonymous

    Logged In: NO

    Before nedit (perhaps 5.5) up scrolling was a problem solved invoking XLIB_SKIP_ARGB_VISUALS=1 nedit
    Now it is not necessary in locale execution of nedit, but the problem still remains with remote nedit.
    I encounter these problem in Ubuntu linux 6.10 and 7.04 (both i386 and x86_64). In other linux distributions nedit works without problems. I don't know why but only Ubuntu is affected.

    > it seems to be some kind of X-related problem, possibly between Motif and X.

     
  • Eddy De Greef

    Eddy De Greef - 2007-05-07

    Logged In: YES
    user_id=73597
    Originator: NO

    What is the remote system?
    Please show us the output of "nedit -V".

    I can imagine that setting the XLIB_SKIP_ARGB_VISUALS variable has no effect if the remote system does not have the X.org libraries (eg. Solaris) but the local system runs an X.org server (eg. Linux).

    Other distros may not have this problem because they don't enable the X composite extension by default. You can try to disable it too (Option "Composite" in xorg.conf), but then you may lose some eye-candy in other applications.

     
  • Stefan Sassenberg

    Logged In: YES
    user_id=1844003
    Originator: NO

    I'd like to have this bug reopened. Can I help to find the cause for it?

     
  • Eddy De Greef

    Eddy De Greef - 2007-07-20
    • assigned_to: nobody --> edg
    • status: open --> pending-fixed
     
  • Eddy De Greef

    Eddy De Greef - 2007-07-20

    Logged In: YES
    user_id=73597
    Originator: NO

    I've reinstated the old 32-bit visual check that tries to avoid ARGB visuals. That check should cover most cases where NEdit is displaying remotely and XLIB_SKIP_ARGB_VISUALS has no effect.
    Can anyone confirm that it works with the latest CVS version?

     
  • SourceForge Robot

    • status: pending-fixed --> closed-fixed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • Nobody/Anonymous

    Logged In: NO

    Platform note: on RedHat FC8/AMD64, the problem exists as described, when using the NEdit.org supplied binary (32 bit version, OpenMotif). Setting XLIB_SKIP_ARGB_VISUALS to 1 seems to solve the problem. (The default RPM version of NEdit, compiled with Lesstif, does not have the scrolling problem, but Lesstif is horribly buggy, and NEdit frequently locks up hard when accessing the clipboard or the Find dialog.)

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks