#19 Window bg menu misbehavior

release
closed-fixed
nobody
None
3
2002-04-11
2001-03-13
Anonymous
No

This bug is not Linux-specific.

I have reproduced it on HP-UX 10.20 both with Nedit
5.1.1 and the devel
version from February 20.

On Fri, 9 Mar 2001, Michael Smith wrote:

> I am unable to reproduce this...
>
> KDE 1.1.2
> Linux 2.2.14-12 RedHat 6.2
> NEdit 5.1.1 Official binary distribution
>
> ...However it does happen if caps lock is on, so I
guess that is the
> reason. However a single click does not fix it for
me as you have described.
>
> But here is a bug I found while investigating this
problem:
>
> With caps lock set on select some text and click
mouse Button3
> The Window background window opens and can not be
closed by clicking
> elsewhere on the workspace. You can even turn off
caps lock, click on
> other bits of text and see the sensitivity of window
background menu
> buttons change as text selection is changed.

Discussion

  • Alexander Mai

    Alexander Mai - 2001-06-06

    Logged In: YES
    user_id=15180

    Just turn on CAPS-LOCk and then MB3?
    Triggers no problem here at all using NEdit/CVS and
    LessTif/CVS.
    Or do I misunderstand the procedure?

     
  • Nobody/Anonymous

    Logged In: NO

    To reproduce this bug on HP-UX 10.20 with Nedit 5.1.1
    and 5.2 (CVS version of 2001-06-1):

    1) Turn on CapsLock
    2) Select some text
    3) Click Button3 - no background menu arising
    4) Turn off CapsLock
    5) Click Button3 again - the menu pops up
    6) Without taking any action, click with the mouse at
    another place - the menu does not disappear.

    The menu remains still operatable though the text pan
    is active and receives characters inserted from the window.

    To get rid of the menu, one has to hit Esc (sometimes for
    several times) or hit an entry in the stuck background menu.

    Yury Burkatovsky <yury.burkatovsky@telrad.co.il>

     
  • Alexander Mai

    Alexander Mai - 2001-08-23
    • priority: 5 --> 3
     
  • Alexander Mai

    Alexander Mai - 2001-08-23

    Logged In: YES
    user_id=15180

    To get things sorted out, I'll lower the priority. We won't have a fix in 5.2 for this ...

     
  • Eddy De Greef

    Eddy De Greef - 2002-04-11
    • status: open --> closed
     
  • Eddy De Greef

    Eddy De Greef - 2002-04-11
    • status: closed --> closed-fixed
     
  • Eddy De Greef

    Eddy De Greef - 2002-04-11

    Logged In: YES
    user_id=73597

    This problem should be fixed in 5.3RC1.
    The background menu is now disabled when
    any of the lock key are on. Due to a Motif bug,
    it doesn't seem to be possible to pop up the
    bg menu in a safe way when any of the lock
    keys are on.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks