fatal: no filesystem

Help
2012-01-06
2012-12-30
  • Michael Streeter

    I have a Nintendo DSi and I am trying to run dslibris on it.  For running homebrew I have M3i Zero flash card.
    I followed the installation instructions (dslibris version 1.4.9) but when I run dslibris I get the message:

         $ dslibris
         fatal: no filesystem
         info: DLDI patch?
    

    This is the problem.  Note there is no DSLIBRIS.LOG file.
    The M3i Zero is supposed to autopatch.  I tried manually patching with Dlditool-win32-gui.
    A binary file compare after manual patching shows changes were made to the .nds file, including:
    "Chishm…Default (No interface)" -> "Chishm…M3 Adapter (SD Card)"

    I tried upgrading the flash card firmware from V1.6.1 to "M3i Zero Core data file V3.0.5" released on 10-12-2011 from handheldsources but it is the same.
    I tried dldinoap to disable autopatching but it was the same. I suspect a problem with my m3sd.dldi file.
    I tried using dslibris 1.4.7 but it is still exactly the same.
    I had a look at the source but cannot find the string or get back to the point where the error is created, so I need help now.
    Can you tell me more about the causes of the "no filesystem" error? 
    Any suggestions?  Please help because I'm desperate to use dslibris - it appears to be the "killer app" for the NDSi - literally worth buying the DSi just to run this software!

     
  • Ray Haleblian

    Ray Haleblian - 2012-01-08

    Greetings,
    This message occurs when libfat can't mount the filesystem on the SD card. Not getting a .LOG file would be expected; dslibris doesn't believe it can write to the card.
    I ran into this in one case where the card was formatted with OS X. In that case, I formatted with Windows as FAT32 to get around it. FAT16 is known to work as well.

    Can I get a show of hands of those who are running ok on DSi?

     
  • Michael Streeter

    The HD was formatted (using Windows XP format drive) as FAT32 when I upgraded the firmware.
    I have re-formatted it anyway, this time using SD Formatter 3.1 produced by the SD Card Association (no less).
    It is definitely formatted using FAT32 block size 32KB card size 7.39GB (SanDisk 8GB MicroSD HC).
    I then copied the back-up of the sd card contents taken before upgrading the firmware back to the card (F_CORE.DAT is the only different file, which is the newer version). There is no write protect tab on the µSDHC.
    It is still exactly the same.  When I boot into the flashcard it loads M3Sakura, then I click on the icon and get.
    $ dslibris
    fatal: no filesystem.
    info: DLDI patch?
    Shall I have a go reformatting with FAT16?  I don't know what else to try. 

     
  • Anonymous - 2012-01-12

    I'd say that was a valiant try. A go at FAT16 is worth it, even just to discount it as a solution.
    I really hope the size of the card isn't a problem. I would think that others are using 8GB cards. I've used 2GB tops.

     
  • Michael Streeter

    Strange.  I have many .nds programs on that card. Most work (three fail with exceptions but until now I had assumed the homebrew setup was a bit unreliable.
    I downloaded devkitPro and ran some of the example programs.  hello_world.nds runs fine but libfatdir.nds says

    fatInitDefault failure: terminating
    

    I'll have a look at the listing and see if I can put some diagnostic messages in there (directory.c) to give me some information as to why.  I'm just of to get the documentation for fatInitDefault() now.  If there's nothing there I'll reformat FAT16 and then trry a 2GB card.
    Thanks for your help.  I'll check back here for other replies at each step and let you know if I solve it or if I run out of leads.

     
  • Anonymous - 2012-01-13

    You're exactly where I am with respect to this. Eager to hear if you learn more.
    It maybe worth trying to build against a newer DKP and libfat. The master branch builds against r34. 1.4.9 was built against something older than r31.

     
  • Anonymous - 2012-01-13

    There is doc missing re: how to arrange dependencies when building from master, wait until I write it down.

     
  • Ray Haleblian

    Ray Haleblian - 2012-01-20

    I've put a hand-build of master branch in the Files section under archive/adhoc/20120119.

     
  • Michael Streeter

    I cannot format the microSD card as FAT16 - neither Windows XP nor SD Formatter provide the option.  Don't know what to do about to get my microSD formatted as FAT16 (I think that may be the issue because - what else is there?!).

    I bought a 2GB microSD card to eliminate the possibility that the size of the card is the problem, but I still get the "fatal: no filesystem" message just the same.

    I haven't yet tried running the devkitPro sample program libfatdir.nds on the 2GB microSD but I'm expecting the same result as when I ran it on the 8GB card. 

    ray23 - Can you explain your comment about "archive/adhoc/20120119" above?  I'm going to start looking at it now.  What should I do with the master branch?                                  

     
  • Anonymous - 2012-01-27

    go into archive/adhoc/20120119 in the Files section, download the dslibris.nds and run it. It's a build against the latest code. It may not make any difference.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks