Ok, let me try this again.

Going from the install documentation ( http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation ):

I've loaded the new ndiswrapper v1.28.  It installed without incident. 

I then installed the windows drivers from the cd as recommended from the list ( http://ndiswrapper.sourceforge.net/mediawiki/index.php/List#D) and when I do a  ndiswrapper -l I get this:
 installed drivers:
dellnic         driver installed, hardware (413C:8104) present
So I'm thinking I'm in good shape at this point, the drivers are loaded as far as I can tell.  No errors yet.

I type "depmod -a", and get no errors so I type "modprobe ndiswrapper" with no errors, then "dmesg" per the installation instructions and I see "[ 17179588.412000] ndiswrapper version 1.28 loaded (preempt=no,smp=yes)".

Problem at this point is, according to the install documentation, I should also see "ndiswrapper: driver ''driver1'' added" in the system log.  I don't see that anywhere in the log.  I tried "dmesg | grep ndiswrapper" and only got 2 lines: 

"[17179588.412000] ndiswrapper version 1.28 loaded (preempt=no,smp=yes)
[17179588.448000] usbcore: registered new driver ndiswrapper"

Remember I'm new to linux, so I may not have done the dmesg grep correctly, so I scanned thru the file and still don't see that line. 

So, i check the /etc/ndiswrapper directory and I see a dellnic directory with 4 files in it.  dellnic.inf, prisma02.sys, 413c:8102.F.conf and 413c:8104.F.conf.

Next thing the install doc says is I should see "wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx". 

I don't see that either.  At this point it looks like the driver isn't loading, but I'm clueless, so please let me know if I'm missing something. I don't know if it helps if I continue with the install directions, but just in case I did continue, and here's what I ran into.

So I run through the configuration of the card real quick, and here's what I get:

mbrown@mbrown-desktop:~$ sudo iwconfig eth2 mode Managed
mbrown@mbrown-desktop:~$ sudo iwconfig eth2 essid home123
mbrown@mbrown-desktop :~$ sudo ifconfig eth2 up
mbrown@mbrown-desktop:~$ sudo iwlist eth2 scan
eth2      No scan results
mbrown@mbrown-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:13:72:73:2F:B5 
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::213:72ff:fe73:2fb5/64 Scope:Link
          RX packets:646 errors:0 dropped:0 overruns:0 frame:0
          TX packets:558 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:304122 (296.9 KiB)  TX bytes:199560 (194.8 KiB)
          Base address:0xcf40 Memory:fe8e0000-fe900000

eth2      Link encap:Ethernet  HWaddr 00:14:A5:3D:05:8C 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 b)  TX bytes:100 ( 100.0 b)

mbrown@mbrown-desktop:~$ iwconfig
lo        no wireless extensions.

eth2      IEEE 802.11b  ESSID:"" 
          Mode:Managed  Channel=1  Access Point: Invalid  
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

sit0      no wireless extensions.

Now I'm stuck.  Don't know where to go for here.

Thanks in advance for any light you can shed on this.


On 11/9/06, Mark Brown <mtbiker1069@gmail.com> wrote:
  Point taken, thanks.  I'll get better information next time.  I'll load the version in the link, and try it again and report back it it doesn't work.

Thanks for your help!,

On 11/8/06, Pavel Roskin <proski@gnu.org> wrote:
On Wed, 2006-11-08 at 22:42 -0600, Mark Brown wrote:
> hey Pavel,
>   Thanks for the quick response.
> I loaded 1.8 and i'm getting closer, but still no luck.
Version 1.8 is actually older than version 1.18!  The latest version is
1.28.  It can be downloaded from

> Now when I do a iwconfig it is showing the SSID that I enter but the
> channel is wrong.

Please don't ever retell error messages.  Exact messages are more
important than your interpretation.  Please set mode to managed, set
ESSID and bring the interface up.  Then see the output of iwconfig and
ifconfig.  If anything seems wrong, please post the exact output and
what you think is wrong there.

>   I turned WEP off on the AP, yes it was a typo, sorry, just to try to
> make it easier to get working initially, but still no luck.  I also
> tried to turn Managed mode on and it says it on, but that didn't
> help.

Again, all I see if your interpretation but no facts for others to form
their own opinions.  Is ESSID still empty?  Does the association fail?
Or maybe you have problems with scanning?

> This adapter works fine in windows, so I don't think it is a hardware
> issue.  My PC Duel boots windows/ubuntu.

OK, this excludes a whole class of possibilities.

It would be helpful if you read this document:

It may be abrasive in some places, but you are likely to get better
replies if you follow the advices contained therein.

Pavel Roskin