I hope it is not inappropriate to send this to this list, but it seemed the most relavent place to include this information. Please write me if I am using this list improperly. Thank you for a great program!!!
Here is the steps I took to get the DWL-G510 card (PCI card in an older
P-II machine) working on my redhat 9.0 linux box. Don't be fooled by the
simplicity of the instructions, it took me 20+ hours, trying a bunch of
thing before I actually got it to work. I tried a few other ways
the pay version of ndiswrapper, Linuxant, but that did not seem to
They have it listed as being supported, but to be honest I did not put
much time into it. Currently, it is on my system interfacing with a
type-B wireless router. Keep in mind I am writing these instructions
I have successfully installed everything, so I do not have the exact
scripting of what it says when I run commands as I do not want to break
by changing something. I do have WEP activated.

1. Install the card in the box and restart the computer.

2. Download ndiswrapper source and recompile. I had to recompile
my kernal was different those RPMs provided by ndiswrapper site.

3. Once ndiswrapper was running, I rebooted just to verify that
was working properly.

4. go to the .inf file location on the cd-rom provided with the card.
access this directory follow these instructions:
a. Mount the cdrom drive if it is not already mounted with "mount
b. To get to this location type "cd /mnt/cdrom/Driver/manual/WinXP/"
c. type "ls", and you should see two files, mrv8k51.inf and MRV8K51.sys

5. Type in command prompt, "ndiswrapper -i mrv8k51.inf"
  *note: I got some type of an error, something like --> Error packet
filter : (FFF0000), but it seemed to work anyway.

6. now you should be able to see the driver by typing "ndiswrapper -l",
will say "mrv8k51 present".
At some point you will need to install this in the module.conf file in /etc/ by running the command "ndiswrapper -m". I did this early, and it did not seem to hurt. Many other instructions seem to address this later in the installation.

7. now if you type iwconfig you should get a display of something to
extent of:

wlan0    IEEE 802.11b ESSID:""
          Mode:Managed  Frequency:2.447GHz  Access Point:
          Bit Rate:54Mb/s   Sensitivity=-200 dBm
          RTS thr:2346 B   Fragment thr:2346 B
          Encryption key:none
          Power Management:off
          Link Quality:100/100  Signal level:-76 dBm  Noise level:-256
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

8. now I was able to configure the card. I did this with two commands:
iwconfig wlan0 key <key value>
iwconfig wlan0 essid <ssid of router>

also you may need to try:
iwconfig wlan0 mode managed
iwconfig wlan0 channel <channel of router>

9. You should be able to tell it is working properly as it will have
key, and it will accept the essid that you entered for the card. For
example mine says:

wlan0     IEEE 802.11b  ESSID:"<my essid>"
          Mode:Managed  Frequency:2.447GHz (this is channel 8)  Access
Point: <access point hex value>
          Bit Rate:11Mb/s   Sensitivity=-200 dBm
          RTS thr:2346 B   Fragment thr:2346 B
          Encryption key:<my key number>   Encryption mode:restricted
          Power Management:off
          Link Quality:100/100  Signal level:-76 dBm  Noise level:-256
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:19  Invalid misc:8215   Missed beacon:0

10. Once this was completed I ran the command "ifconfig wlan0 up" to
the wlan0 interface up. This sends some weird messages to the term.
Something to the extent of:

PCI 4 -> 6 (000:000)
Error packet filter : (FFF00000)
Error packet filter : (FFF00000)
Error packet filter : (FFF00000)

but it still seems to work. Now you should be able to type ifconfig and
will return this:
wlan0     Link encap:Ethernet  HWaddr <12 byte hex address)
          inet addr:  Bcast: 
          RX packets:4407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1767 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:545850 (533.0 Kb)  TX bytes:484637 (473.2 Kb)
          Interrupt:11 Memory:fede0000-fedeffff

If it does not have the line:
          inet addr:  Bcast: 

Then this means it does not have an ip address and it is not
with the router. I solved this problem by typing "dhclient wlan0",
gave it a DHCP IP address. It needs to have the IP address to work
addr line).

11. I am having issues with it resolving host names. It will
resolve a host name when I first start up, but if it ever loses contact
with the router, or gets reset it will not work again till I bring up
down the interface. To be honest I do not know the command for
the DNS list.

12. In order to get this interface to work properly on the startup, I
the following values in my "ifcfg-wlan0" file in the directory
"/etc/sysconfig/network-scripts/". These may or may not work for you.
reason that it does not have ONBOOT as yes, is because I send the
through an rc3.d script, which I will explain later. I cannot get it to
work if I try to start it on boot through this file. Only by doing an
rc3.d script. Setting key and essid name in this file did not seem to
help. setting peerdns to yes also appeared to break the connection.


13. I added the following script file to the "/etc/rc.d/rc3.d"
I called it "S99wwwlan0" so that it is run last.
It contains the following:

# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

iwconfig wlan0 key <wireless key>
iwconfig wlan0 essid "<essid>"
ifconfig wlan0 up
dhclient wlan0

14. After adding that file, it appears that when I restart my computer
works successfully.

If you have any ideas/comments/additions, etc, please feel free to
me at mntdewdan@yahoo.com .

Please write me and tell me if these instructions help!


Do you Yahoo!?
Yahoo! Mail is new and improved - Check it out!