I've installed ndiswrapper in Gentoo and downloaded the correct .inf for my chipset. The PCI ID is 14e4:4320 and the driver required for this is bcmwl5.inf. I've done "ndiswrapper -i bcmwl5.inf" but when I do "ndiswrapper -l" it says it's an invalid driver. I've tried this with two different bcmwl5.inf files but I keep getting the same problem. I tried binding the driver to my card by doing "ndiswrapper -d 14e4:4320 bcmwl5" but it says it wasn't installed properly.

I've had this card working under ndiswrapper before under Slackware using the above methods so I'm confused as to why it's not working now.

I don't know if it's related but I have noticed that dmesg has a few errors stating "IRQ routing conflict for 0000:00:10.0, have irq 12, want irq 3".

Any ideas?