Greetings all,
Recently I was told to set up a wireless network, and I got myself a new Cisco card that does 801.11a b and g ... The number on the back is: AIR-CB21AG-A-K9.  It is a cardbus card, and I'm trying to get it to work in an IBM T22 laptop.  The slot does work fine, as an older orinoco card works in it. 

First I tried the aironet drivers from a 2.4 kernel, with no joy.  I upgraded to 2.6.3, and realized that this card is a different beast than what the drivers were expecting.  So I thought I'd give ndiswrapper a whirl.  I got the drivers from, who has a lovely option in their installer program to "copy install files to floppy".  I pointed it at a directory on my harddrive, and got the drivers that way.  I copied them to my laptop, and compiled ndiswrapper 0.5.  Everything went just fine.  When i tried ndiswrapper -l after using -i on the .inf file, I got this output:

bash-2.05b# ndiswrapper -i net21.inf
Installing net21
bash-2.05b# ndiswrapper -l
Installed ndis drivers:
net21   present,fuzzy

I'm not sure what fuzzy means, but I pressed on anyway.  Loading up the ndiswrapper kernel module seemed ok, but I got this error in my logs:

ndiswrapper version 0.5 loaded
ndiswrapper adding csco21.sys
PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:06:00.0 to 64
general protection fault: 0000 [#1]
CPU:    0
EIP:    0060:[<d8a08f62>]    Tainted: P 
EFLAGS: 00010282
EIP is at 0xd8a08f62
eax: 00000000   ebx: c0bb0000   ecx: d5e85b38   edx: d199de00
esi: c0bb0898   edi: ffffffff   ebp: d0b41a20   esp: d5e85d84
ds: 007b   es: 007b   ss: 0068
Process loadndisdriver (pid: 17115, threadinfo=d5e84000 task=c78cb900)
Stack: c001001b d5e85e04 d5069400 d0b41a20 d89dde44 00000000 00180016 d8a0a430
       00180016 d8a0a448 d89d88c9 d5e85dc8 d67c7fb0 d0b41a20 00000000 d0b41a20
       d0b41a20 00000006 00000000 00000000 00000001 00000002 00000003 00000004
Call Trace:
 [<d89d88c9>] call_init+0x39/0x50 [ndiswrapper]
 [<d89d9631>] ndis_init_one+0x1f1/0x2a0 [ndiswrapper]
 [<c02a40f2>] pci_device_probe_static+0x32/0x50
 [<c02a4137>] __pci_device_probe+0x27/0x40
 [<c02a416c>] pci_device_probe+0x1c/0x40
 [<c02e924e>] bus_match+0x2e/0x60
 [<c02e9367>] driver_attach+0x47/0xa0
 [<c02e95c6>] bus_add_driver+0x56/0x80
 [<c02e996d>] driver_register+0x2d/0x40
 [<d89d892e>] call_entry+0x2e/0x40 [ndiswrapper]
 [<c02a431e>] pci_register_driver+0x4e/0x70
 [<d89d98b6>] start_driver+0x136/0x170 [ndiswrapper]
 [<d89da113>] misc_ioctl+0x153/0x290 [ndiswrapper]
 [<c0146c41>] unmap_region+0x81/0xd0
 [<c0151de4>] __fput+0x94/0x100
 [<c0160ce2>] sys_ioctl+0x1e2/0x220
 [<c0150865>] sys_close+0x45/0x60
 [<c010afc7>] syscall_call+0x7/0xb

Code: 65 00 67 00 41 00 64 00 64 00 2e 00 74 00 78 00 74 00 00 00

Ouch.  Never seen linux GPF before, and I've been working with it for a few years now!  Anyway, i'd be more than happy to try to help get this to work, obviously, since it would benefit me greatly!  Any help someone could pass on would be great.  Cisco only has drivers for XP and 2000, and a google search for this card with linux didn't turn up much of anything.  Thanks in advance!