-Le Thu, Nov 18, 2004 at 12:19:35AM -0700, Erich Pletsch [erich@uv...] a écrit:
- > I am attempting to make ndiswrapper from source (have tried with both the release and
-most recent rc1 sources).
->
-> Part of the make output includes:
->
-> ***unresolved symbols in /lib/modules/2.4.21-20.EL/misc/ndiswrapper.o
->
-> So, I run "depmod -ae" to see what"s missing.  It lists the following:
->
-> usb_init
-> usb_reset_port
-> usb_submit_nt_urb
-> usb_exports
- >
-> I have libusb and libusbdevel 0.1.6-3 installed on my system
-> I also have usbutils 0.11-1 installed on my system
-
- When depmod spits errors about unresolved symbols, it"s because these
-symbols are missing in the kernel an modules, nothing to do with
-libraries installed on your system.
-You should get a kernel with USB support (at lest as a module) or try
-and see if USB can be disabled in ndiswrapper...
-
- >
Dominique, thanks for your insight. 
 
I checked my kernel config and USB is installed.  I can't find much USB related in the config file that is not already compiled into the kernel either directly or as a module.
 
Does anyone have any idea how I can disable USB support in ndiswrapper?
 
I have noted that on google several other people have had this exact same problem, but none have received responses to their inquiries.
 
If I figure this out, I'll certainly post the fix.
 
Thanks in advance.