Firstly, my apologies if I've done something stupid.  I'm a complete newbie to linux. I did used to do some Unix sysadmin work years ago, but I'm just trying to get a 'real' operating system in use at home.  I've recently loaded Mandrake 10 on my Toshiba laptop and I may have tried to run before walking by attempting to get wireless networking going.
 
I downloaded nidswrapper 0.8, found the kernel source and everything compiled and installed just fine.  I was following the instructions in a helpful article by ByteEnable on www.linuxelectrons.com : http://www.linuxelectrons.com/article.php?story=20040507104718960&mode=print (Is there a step-by-step guide on the project pages or in the download?  I couldn't see one.)
 
I have a Linksys WPC54g PCMCIA card, which came with the Broadcom bcmwl5.sys driver although the .inf file has been customised.  I checked the card and the chipset identifies as 14E4:4320 - which corresponds with the same drivers on the supported drivers page.
 
The problem I get when I try to modprobe is:
 
ndiswrapper: no version for "struct_module" found: kernel tainted.
ndiswrapper version 0.8 loaded
ndiswrapper adding bcmwl5.sys
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
PCI BIOS passed nonexistent PCI bus 3!
PCI: No IRQ known for interrupt pin @ of device 0000:03:00.0. Probably buggy MP table.
PCI: Setting latency timer of device 0000:03:00.0 to 64
ndiswrapper: Windows driver couldn't initialize the device
bcmwl5.sys: probe of 0000:03:00.0 failed with error -22
 
I have checked the FAQ - and I did remove any existing Mandrake ndiswrapper as suggested.  I have tried both the supplied driver version and the one referenced by the supported drivers page.  (Same result.)
 
There is no /proc/net/wireless on my machine when running - but I have checked the kernel conf and the CONFIG_NET_RADIO does equal 'y'.  I'm assuming that the supplied kernel binary corresponds with the config file as supplied.  I haven't yet plucked up the nerve to recompile the kernel - like I said, I'm a newbie, I'll get there soon.  Is the above error what you would expect if there is no wireless support in the kernel?  It doesn't suggest that.
 
Finally - the FAQ mentions that you might get this error if you didn't shut down PCMCIA before doing the modprobe - but I tried stopping it as suggested and I still get the same message.
 
I didn't like the bits in dmesg about a non-existent bus, and no interrupt.  Windows reports that it is runs the card as PCI Bus 3, device 0, function 0 on IRQ 16.  Should I have configured this information somewhere for ndiswrapper to pick up?
 
Any suggestions most welcome - and thanks for a really useful project by the way:-)
 
MikeE