Drivers all invalid in Ndis 1.1

Help
taki
2005-03-22
2012-10-06
  • taki

    taki - 2005-03-22

    Okay, so I finally got ndiswrapper 1.1 configured and linked to the proper headers in Ubuntu Hoary 5.04 (x86).

    I have a Belkin f5d700 pci card, with a Broadcom bcm4306 (rev 02) chip.

    I have tried both bcmwl5.inf as well as bcmwl5a.inf (from the Dell drivers).

    Neither one will install... I get 'invalid driver!' for either one.

    I'm a bit confused as to what I can try. Actually, I tried a couple other drivers to test to see what card to buy if this fails, and they all give me invalid driver! as well. For example, the mrv8ka51.inf for the Asus WL-138G, which is supposed to be pretty problem free. I'm guessing something's wrong with Ndiswrapper, but I have no idea what.

     
    • taki

      taki - 2005-03-22

      Just to update, I've tried compiling and installing 1.0, .12 and .11 just to see if it's a version thing. And the latest nightly of 1.1. No luck with any of them.

      ndiswrapper -l

      constantly gives me the message 'invalid driver!' for any of the drivers I try installing,

       
    • taki

      taki - 2005-03-22

      Okay. Found the problem. Didn't have the proper .sys file accompanying it. I didn't see that mentioned anywhere, on any web pages. All I ever saw was references to the .inf file. I feel like an idiot.

       
    • Pedro F

      Pedro F - 2005-05-19

      Excuse me, I am a beginer... What is this thing of the "proper headers"

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks