Angel Galindo - 2011-01-02

Hello everybody!

I'm unsuccessfully trying to load Windows XP wireless drivers via
ndiswrapper for the "RTL8192SE" on a Shuttle XS35GT with XBMC Live
10.0
. XBMC Live 10.0 is based on Ubuntu 10.4 LTS.

I made these steps:

I read this

I avoided the loading of the present module r8192se_pci (packed on XBMC Live
10.0):

apt-get install ndiswrapper-common ndiswrapper-utils-1.9
echo “blacklist r8192se_pci” >> /etc/modprobe.d/blacklist.conf

and rebooted instead of doing rmmod , just for verifying it works

downloaded drivers for "RTL8192SE" from Realtek and unpacked them , having a
"net8192se.inf"

installed the driver:

ndiswrapper -i  /.../91_92_SE_Driver/WinXP/net8192se.inf

and then appears a folder /etc/ndiswrapper/net8192se/ and "ndiswrapper -l"
lists a new driver "net8192se"

verified dependencies:

depmod -a

and tried to load ndiswrapper but "modprobe ndiswrapper" fails this
way:

# modprobe ndiswrapper
ndiswrapper (import:242): unknown symbol: ntoskrnl.exe: IoWMIQueryAllData
ndiswrapper (import:242): unknown symbol: ntoskrnl.exe: IoWMIOpenBlock
ndiswrapper (import:242): unknown symbol: NDIS.SYS: NdisMCreateLog
ndiswrapper (import:242): unknown symbol: NDIS.SYS: NdisMCloseLog
ndiswrapper (import:242): unknown symbol: NDIS.SYS: NdisMWriteLogData
ndiswrapper (load_sys_files:206): couldnt prepare driver net8192se
ndiswrapper (load_wrap_driver:108): couldnt load driver net8192se; check system log for messages from loadndisdriver

Also tried to compile ndiswrapper from source, but looks like make
install
doesn't the work (or I'm fooling), ndiswrapper -v keeps showing
v1.55 (the ones from XBMC Live 10.0) instead of the compiled 1.56.

Can anybody help me, please?
Thanks in advance!

/ Angel