William - 2007-03-11

running the lastest FC6 kernel 2911.6.5, downloaded NdisWrapper 1.38, make,
make install.

when I do 'modprobe ndiswrapper', i get this:

Mar 11 15:44:45 localhost kernel: ndiswrapper: version magic '2.6.19-1.2911.6.5.fc6 SMP mod_unload 686 REGPARM 4KSTACKS ' should be '2.6.19-1.2911.6.5.fc6 SMP mod_unload 586 REGPARM 4KSTACKS '

[root@localhost NDISWrapper]# cat /proc/version
Linux version 2.6.19-1.2911.6.5.fc6 (brewbuilder@ls20-bc1-13.build.redhat.com) (gcc version 4.1.1 20070105 (Red Hat 4.1.1-51)) #1 SMP Sun Mar 4 15:47:41 EST 2007
[root@localhost NDISWrapper]# ndiswrapper -v
utils version: 1.9
driver version: 1.38
vermagic: 2.6.19-1.2911.6.5.fc6 SMP mod_unload 686 REGPARM 4KSTACKS
[root@localhost NDISWrapper]#


How can I get ndiswrapper to compile for a 586?