FRITZ!WLAN USB Stick on Fedora Core 5

Help
thermostat
2006-11-18
2012-10-06
  • thermostat

    thermostat - 2006-11-18

    I try to use the AVM FRITZ!WLAN USB Stick on Fedora Core 5 (64 bit) with ndiswrapper 1.28 which is reported in the wiki list to work (device ID: 057c:6201). As in the list I use the english x64 Windows driver though with the german version it is the same.

    If I try to load the ndiswrapper kernel module, there are two possibilities. Either the network interface wlan0 is created and I can set up a connection. In this case the device seems to work okay, however in dmesg an error message appears (message 1, in the end of the post). The other possibility is that wlan0 is not created, then another error message appears (message 2).

    There is no logical order in which these things appear. Sometimes I can directly after booting load ndiswrapper (with error message 1) and set up a connection to the access point, sometimes I can't and (error message 2 appeared in dmesg), however, in many cases I can set up the network interface after removing and loading the ndiswrapper module a few times. It's absolutely unpredictable.

    I tried to boot with acpi turned off and I tried to remove the ehci_hcd module, but neither did help. With the vanilla kernel 2.6.18.1 shipped with fedora it's the same.

    BTW: The error messages say 'preempt=no'. What does that mean, and does it have to be like this? As usual, my kernel is preemptable.

    MESSAGE 1:

    ndiswrapper version 1.28 loaded (preempt=no,smp=yes)
    usb 2-6.1: reset high speed USB device using ehci_hcd and address 4
    ndiswrapper (link_pe_images:577): fixing KI_USER_SHARED_DATA address in the driver
    ndiswrapper: driver fwlan64 (AVM GmbH,07/31/2006,2.0.4.1482) loaded
    BUG: sleeping function called from invalid context at mm/slab.c:2901
    in_atomic():1, irqs_disabled():0

    Call Trace:
    [<ffffffff8026a231>] dump_stack+0x12/0x17
    [<ffffffff802c96ef>] kmem_cache_alloc_node+0x29/0xc4
    [<ffffffff802bf71f>] get_vm_area_node+0x67/0x17b
    [<ffffffff802bfec3>]
    vmalloc_node+0x38/0x58
    [<ffffffff88411984>] :ndiswrapper:NdisAllocateMemoryWithTag+0xd/0x20
    [<ffffffff88421e2b>] :ndiswrapper:win2lin3+0x11/0x14
    DWARF2 unwinder stuck at win2lin3+0x11/0x14 [ndiswrapper]
    Leftover inexact backtrace:
    [<ffffffff88421e06>] :ndiswrapper:win2lin1+0xb/0xe
    [<ffffffff802637e6>] _spin_lock_irqsave+0x9/0xe
    [<ffffffff8023ec8d>] lock_timer_base+0x1b/0x3c
    [<ffffffff88421e2b>] :ndiswrapper:win2lin3+0x11/0x14
    [<ffffffff884193eb>] :ndiswrapper:IofCompleteRequest+0x7d/0x11c
    [<ffffffff8841acfe>] :ndiswrapper:pdoDispatchPnp+0x409/0x414
    [<ffffffff8841e049>] :ndiswrapper:miniport_init+0xa2/0x127
    [<ffffffff8841a036>] :ndiswrapper:IoSyncForwardIrp+0x62/0x88
    [<ffffffff8841e14b>] :ndiswrapper:NdisDispatchPnp+0x73/0x729
    [<ffffffff88419682>] :ndiswrapper:IoAllocateIrp+0x73/0x7b
    [<ffffffff88421e17>] :ndiswrapper:win2lin2+0xe/0x11
    [<ffffffff88418af9>] :ndiswrapper:IofCallDriver+0x3d/0x67
    [<ffffffff884199d0>] :ndiswrapper:IoBuildSynchronousFsdRequest+0x27/0x2e
    [<ffffffff8841adc7>] :ndiswrapper:IoSendIrpTopDev+0x97/0xcd
    [<ffffffff8841b04d>] :ndiswrapper:pnp_start_device+0x45/0x88
    [<ffffffff8841b28c>] :ndiswrapper:wrap_pnp_start_device+0x1fc/0x223
    [<ffffffff8841b51b>] :ndiswrapper:wrap_pnp_start_usb_device+0xc6/0xcf
    [<ffffffff802571ec>] netlink_broadcast+0x29c/0x2e5
    [<ffffffff803cc1ca>] usb_probe_interface+0x6c/0x9e
    [<ffffffff8039a78f>] driver_probe_device+0x52/0xa8
    [<ffffffff8039a8ee>] driver_attach+0x86/0xd4
    [<ffffffff8039a868>]
    driver_attach+0x0/0xd4
    [<ffffffff8039a1a3>] bus_for_each_dev+0x43/0x6e
    [<ffffffff80399de2>] bus_add_driver+0x7e/0x130
    [<ffffffff803cc079>] usb_register_driver+0x74/0xd6
    [<ffffffff8840f9b5>] :ndiswrapper:loader_init+0x1f5/0x227
    [<ffffffff8810408f>] :ndiswrapper:wrapper_init+0x8f/0xc4
    [<ffffffff802a25b2>] sys_init_module+0x1701/0x18c6
    [<ffffffff8025d00e>] system_call+0x7e/0x83

    wlan0: vendor: 'AVM FRITZ!WLAN USB Stick'
    wlan0: ethernet device 00:04:0e:fa:68:ab using NDIS driver fwlan64, 057C:6201.F.conf
    wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
    usbcore: registered new driver ndiswrapper

    MESSAGE 2

    ndiswrapper version 1.28 loaded (preempt=no,smp=yes)
    usb 2-6.1: reset high speed USB device using ehci_hcd and address 4
    ndiswrapper (link_pe_images:577): fixing KI_USER_SHARED_DATA address in the driver
    ndiswrapper: driver fwlan64 (AVM GmbH,07/31/2006,2.0.4.1482) loaded
    ndiswrapper (miniport_init:269): couldn't initialize device: C000009A
    ndiswrapper (pnp_start_device:426): Windows driver couldn't initialize the device (C0000001)
    unregister_netdevice: device eth%d/ffff81006ea62000 never was registered
    ndiswrapper (miniport_halt:326): device ffff81006ea62500 is not initialized - not halting
    ndiswrapper: device eth%d removed
    ndiswrapper: probe of 2-6.1:1.0 failed with error -22
    usbcore: registered new driver ndiswrapper

     
    • thermostat

      thermostat - 2006-11-19

      Actually my default kernel has voluntary preemption enabled, concerning to the .config file. However, if I compile the kernel with full preemption enabled, ndiswrapper recognizes it.

      I have compiled the 2.6.19-rc6 kernel, but unfortunately I couldn't boot it - it said something like it couldn't mount /dev/root, /sys and /proc at boot time and there was a kernel panic. However, I inserted kernel/module.c and include/linux/module.h from 2.6.19 into 2.6.18, and the first message kept after compiling and booting it - maybe I did something wrong? I have searched the web and the ndiswrapper patch in the kernel seemed to affect only module.c.

      If if compile ndiswrapper with the boot options DEBUG=6 IO_DEBUG=1 EVENT_DEBUG=1 USB_DEBUG=1 and insert it with debug=3, there is a bug trace I have posted at

      http://ultrashare.net/hosting/fl/1e76e9f2a2

      because of its large size. I have rebooted and loaded the driver a few times until the module couldn't set up wlan0.

       
    • Giridhar Pemmasani

      First message is due to a bug in kernel. It is fixed in 2.6.19-rc4. To understand second error, debug trace is needed (see wiki entry Bugs).

      Kernel can be compiled with or without preempt and your kernel has been compiled without preempt. Usually it is a good idea to enable preempt.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks