Can't install ndiswrapper

Help
Anonymous
2004-09-08
2012-10-06
  • Anonymous - 2004-09-08

    Hi all

    I have recently started to use Linux through Mandrake 10.0 distribution and would like to use ndiswrapper to configure my Linksys WMP54G card.

    Unfortunately, after searching several hours where my mistake was I have to admit I can't install it on my computer, even though it seems I have the kernel source available :

    [root@localhost ndiswrapper-0.10]# urpmi kernel-source
    Tout est dj install
    [root@localhost ndiswrapper-0.10]# make install
    make -C driver install
    make[1]: Entering directory `/home/gecko/Documents/ndiswrapper-0.10/driver'
    make -C /lib/modules/2.6.3-7mdk/build
    SUBDIRS=/home/gecko/Documents/ndiswrapper-0.10/driver \
            NDISWRAPPER_VERSION=0.10 \
            EXTRA_VERSION= modules
    make[2]: Entering directory `/lib/modules/2.6.3-7mdk/build'
    make[2]: *** Pas de rgle pour fabriquer la cible  modules . Arrt.
    make[2]: Leaving directory `/lib/modules/2.6.3-7mdk/build'
    make[1]: *** [default] Erreur 2
    make[1]: Leaving directory `/home/gecko/Documents/ndiswrapper-0.10/driver'
    make: *** [install] Erreur 2

    Here is a copy of a few ls commands results :

    [root@localhost ndiswrapper-0.10]# ls -al /usr/src
    total 16
    drwxr-xr-x   4 root root 4096 sep  8 21:55 ./
    drwxr-xr-x  12 root root 4096 sep  7 00:54 ../
    lrwxrwxrwx   1 root root   16 sep  8 21:55 linux (turquoise)->
    linux-2.6.3-7mdk/ (bleu)
    drwxr-xr-x  20 root root 4096 sep  8 21:54 linux-2.6.3-7mdk/ (bleu)
    drwxr-xr-x   3 root root 4096 sep  7 00:37 RPM/ (bleu)

    [root@localhost ndiswrapper-0.10]# ls -al /lib/modules/2.6.3-7mdk/build
    total 8
    drwxr-xr-x  2 root root 4096 sep  8 21:55 ./
    drwxr-xr-x  4 root root 4096 sep  8 22:08 ../
    lrwxrwxrwx  1 root root   25 sep  8 21:55 linux-2.6.3-7mdk (turquoise)
    -> /usr/src/linux-2.6.3-7mdk/ (bleu)

    Finally, I decided to use the ndiswrapper version which comes with Mandrake 10.
    if I manage to install it, the command seems not to be recognized by the system !
    [root@localhost DriversLinksys]# ndiswrapper -i bcmwl5.inf
    bash: ndiswrapper: command not found

    Could anyone please help me finding a solution to my problem?

    Thanks a lot in advance!!!

     
    • xNaN0x

      xNaN0x - 2004-09-09

      just a question, but did you strictly type "make install" if you did then you need to type "make" first then do "make install."

      if you decide to run "make" again then you should type "make clean" first then type "make."

       
    • Anonymous - 2004-09-09

      Hello xNaN0x

      Thanks for your answer.
      Here is the result of the "make" command :

      [root@localhost ndiswrapper-0.10]# make
      make -C driver
      make[1]: Entering directory `/home/gecko/Documents/ndiswrapper-0.10/driver'
      You don't seem to have sources for your kernel;  install them in /usr/src,
      link /lib/modules/2.6.3-7mdk/build to it and try again.
      make[1]: *** [prereq_check] Erreur 1
      make[1]: Leaving directory `/home/gecko/Documents/ndiswrapper-0.10/driver'
      make: *** [all] Erreur 2

      What I do not understand is that the source of the kernel seem to be installed (see above commands) !!

      Any idea what I shall do??

       
    • xNaN0x

      xNaN0x - 2004-09-09

      this is just a guess but what does uname give as an output?

      was there any errors produced when you installed the rpm of ndiswrapper for mandrake?

      if the rpm didn't produce any errors, then look in the /usr/sbin directory to see if the ndiswrapper command exists. you could also after installing the rpm do "updatedb", this will take a few minutes, and then do "locate ndiswrapper | more" to see all the matches. look for anything that would be outside the ndiswrapper source directory.

       
    • Anonymous - 2004-09-09

      Here is the result of the command :
      [root@localhost gecko]# uname
      Linux

      Regarding the installation of the ndiswrapper version which comes with Mandrake 10.0 : no, I did not have any mistake.
      On the contrary, I had confirmation the installation went fine.

      I checked directory /usr/sbin : I do not have any ndiswrapper command.
      But when I have a look at the uninstallation program, ndiswrapper appears, so it seems to be installed.

      As you mentionned, i did "updatedb".
      Here is the result of the locate ndiswrapper command you mentionned :

      [root@localhost gecko]# locate ndiswrapper | more
      /home/gecko/.kde/share/apps/RecentDocuments/ndiswrapper-0.4-1mdk.i586.rpm[2].desktop
      /home/gecko/.kde/share/apps/RecentDocuments/ndiswrapper-0.4-1mdk.i586.rpm.desktop
      /home/gecko/.kde/share/apps/RecentDocuments/ndiswrapper-0.4-1mdk.src.rpm.desktop
      /home/gecko/.kde/share/apps/RecentDocuments/ndiswrapper-0.4-1mdk.src.rpm[2].desktop
      /usr/share/doc/ndiswrapper-0.4
      /usr/share/doc/ndiswrapper-0.4/ChangeLog
      /usr/share/doc/ndiswrapper-0.4/README
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/Makefile
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/Kconfig
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/misc_funcs.c
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/casemap.h
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/coffpe.h
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/loader.c
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/loader.h
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/winsyms.c
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/ndis.c
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/ndis.h
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/proc.c
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/winsyms.h
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/wrapper.c
      /usr/src/linux-2.6.3-7mdk/3rdparty/ndiswrapper/wrapper.h
      /lib/modules/2.6.3-7mdk/kernel/3rdparty/ndiswrapper
      /lib/modules/2.6.3-7mdk/kernel/3rdparty/ndiswrapper/ndiswrapper.ko.gz

      Thanks again for your help!

       
    • xNaN0x

      xNaN0x - 2004-09-09

      see if you can find a more up-to-date rpm.  second thing I notice is that there doesn't seem to be an /etc/ndiswrapper directory. that is usually where the .inf files would be put, huh!

      i'll have to think about this some more.

      if you feel adventurous I could tell you how to make the .4 version a .10 version with the old src.rpm scripts.

       
    • Anonymous - 2004-09-09

      Hi xNaN0x!

      Yes indeed, there is something really strange, just like the answer "You don't seem to have sources for your kernel; install them in /usr/src" to a make command while it seems to be there...

      Before uninstalling/reinstalling the whole Mandrake, I decided to install the trial version of Linuxant DriverLoader and everything went fine!!!!! :-)))
      I had to configure my card manually to make it communicate with my own router, as it started to connect by default to the new AP of one of my neighbour who has not put in place any protection (MAC adress, WEP...). He seems to have quite a nice internet access ;-)

      Anyway, I am really happy to be able to get rid of my Ethernet cable but time is runnnig and don't feel like paying 20$ for Linuxant solution :-(

      All your ideas are most welcome!

      Thanks again!!

       
    • xNaN0x

      xNaN0x - 2004-09-10

      here is link to get a .9 version, if you are interested. I can't to be sure if it will work since it is from the cooker area.  I have a mandrake 10.0 version installed on one of my computers, but I don't have wireless on it so i can't really finish the testing. the install of the .9 rpm went fine and the ndiswrapper command was where it was supposed to be.

      ftp://mirror.cs.wisc.edu/pub/mirrors/linux/Mandrakelinux/devel/cooker/i586/Mandrake/RPMS/

      I also decided to try the source from ndiswrapper, and it went fine no problems. In fact the only problems i had was that I didn't have the source kernel installed and so I did that. I had to solve some dependencies. first was installing glibc-devel , gcc, and ncurses-devel. you should check to make sure you have these installed as well.

      "rpm -q gcc", "rpm -q glibc-devel", and "rpm -q ncurses-devel"

      to get the ncurses-devel i had to get the fedora-core version.
      http://www2.linuxforum.net/RPM/ncurses-devel.html

      just for grins try "rpm -q kernel-source" and see what it says.

      you could also reinstall the kernel source, but this shouldn't be necessary if it exists. let me know how it goes.

       
    • Anonymous - 2004-09-10

      I can not access your ftp link as there seem to be no "Mandrake" directory in i586.

      gcc and glibc-devel are aleady installed on my computer

      [root@localhost gecko]# rpm -q gcc
      gcc-3.3.2-6mdk
      [root@localhost gecko]# rpm -q glibc-devel
      glibc-devel-2.3.3-10mdk

      I downloaded ncurses-devel from your link and installed it.
      During the installation, I received the message "Everything is already installed".

      Finally, here is the answer to the last command you mentionned :
      [root@localhost gecko]# rpm -q kernel-source
      kernel-source-2.6.3-7mdk

      What shall I do next?

       
    • xNaN0x

      xNaN0x - 2004-09-10

      go to another mirror site provided by mandrake that has the devel/cooker directory available, or you could try this site. make sure you click on the appropriate architecture.

      http://rpmfind.net/linux/rpm2html/search.php?query=ndis

      one more thing did you install the kernel from somewhere other than installation discs? if so, try installing the source from the discs.

       
    • Anonymous - 2004-09-10

      Really sorry for asking what is probably a stupid question, but I am really a beginner with Linux : what is devel/cooker? Does it mean it is a Beta version?

      I found 3 different files for ndiswrapper 0.9 :
      ndiswrapper-0.9-1mdk.ppc.rpm
      ndiswrapper-0.9-1mdk.src.rpm
      ndiswrapper-0.9-1mdk.i586.rpm

      What are the differences between these files? Does it depend on the kind of system on which Linux is installed?
      I use an athlon xp1800 based pc. Shall I take the "i586" version?

      For your question, I installed the kernel from the mandrake 10.0 CD. Shall I try to uninstall/reinstall?

       
    • xNaN0x

      xNaN0x - 2004-09-10

      ppc stands for Power PC it is a chip style that more commonly known to be in macs.

      src stands for source, this means that that package would have the source rpm. that also means that when you install it i.e. rpm -ivh it leaves a few files in the /usr/src/rpm subdirectories that will be used to build a binary version (normal executable rpm).  to build the rpm you would go into ./rpm/SPECS and type "rpmbuild -bb foo.spec" this will in turn start compiling the tar.gz file left in ./rpm/SOURCE. when it is done it will leave a rpm binary for a person to install.

      i586 stands for x86 architecture type that is very common. athlon supports i386 to i686 and some of the other various chip designs (won't go into that right now). so in your case, yes, take i586.

      devel/cooker implies that these will be the packages that will be in the next mandrake version. cooker is nothing more than a metaphor for whats currently being tested.  so when you go to a mirror site for mandrake and you want the rpm that would be in the next release you would navigate to devel then go into cooker. if you look at the link I gave you would see that it has no reference to a version of mandrake other than what chipset its in.

      as far as the kernel goes it won't hurt to unistall and reinstall the source kernel.

       
    • Anonymous - 2004-09-11

      YES!!!
      The ndiswrapper package you gave me has been successfully installed on my pc!
      After entering the command "updatedb", the ndiswrapper command is recognized.

      New problem though :-(
      I have tried to install the CD based driver for my WMP54G.
      The 1st steps run fine :

      [root@localhost DriversLinksys]# ndiswrapper -i bcmwl5.inf
      Installing bcmwl5
      [root@localhost DriversLinksys]# ndiswrapper -l
      Installed ndis drivers:
      bcmwl5  hardware present
      [root@localhost DriversLinksys]# modprobe ndiswrapper
      [root@localhost DriversLinksys]#

      Unfortunately, the only return I have to dmesg is "ndiswrapper version 0.4 loaded" without a "ndiswrapper driver....." line as it is mentionned in the install manual.

      I have no wlan0 interface available :

      [root@localhost DriversLinksys]# iwconfig
      lo        no wireless extensions.

      eth0      no wireless extensions.

      sit0      no wireless extensions.

      I have tried several other drivers which are mentionned on this forum, having always the same result.
      Do you have any idea what I shall do next?

      My WMP54G seem to be a v2 (mentionned on the box) and here is the result of the lspci command :
      [root@localhost DriversLinksys]# lspci -n
      00:00.0 Class 0600: 1106:3099
      00:01.0 Class 0604: 1106:b099
      00:07.0 Class 0280: 14e4:4320 (rev 03)
      00:08.0 Class 0200: 10ec:8139 (rev 10)
      00:09.0 Class 0401: 1102:0002 (rev 07)
      00:09.1 Class 0980: 1102:7002 (rev 07)
      00:11.0 Class 0601: 1106:3074
      00:11.1 Class 0101: 1106:0571 (rev 06)
      00:11.2 Class 0c03: 1106:3038 (rev 1b)
      00:11.3 Class 0c03: 1106:3038 (rev 1b)
      00:11.4 Class 0c03: 1106:3038 (rev 1b)
      00:11.5 Class 0401: 1106:3059 (rev 10)
      01:00.0 Class 0300: 10de:0201 (rev a3)

      I want to thank you again for the all the detailed explanations you take time to provide me with.
      I really appreciate.

       
    • Anonymous - 2004-09-11

      FYI, I noticed that in the /etc/ndiswrapper/bcmwl5 folder, I have 5 .conf files on top of the .inf and .sys :
      14E4:4301
      14E4:4307
      14E4:4320
      14E4:4321
      14E4:4324

      Shall I keep only the "4320", as it seems to correspond to my card?
      If yes, shall I configure something manually in this file?

       
    • Anonymous - 2004-09-11

      Another question : is the message "ndiswrapper version 0.4 loaded" ok?

      Should not I get "ndiswrapper version 0.9.1 loaded"??

      I uninstalled the v0.4 included in Mandrake 10.0 before installing the one you provided me with.

       
    • xNaN0x

      xNaN0x - 2004-09-11

      if you ask me, all things relating to ndiswrapper should be removed, that includes the .9 version.  do this manually first by unistalling the rpms then using locate find the directories that contain ndiswrapper and remove them. you must make sure the only .9 is loaded when you reinstall.

      there is no need to be concerned with what card number to keep in the /etc/ndiswrapper directory.

      once you have done the unistall and removal of files, and then reinstall .9 let me know how it goes.

      by the way the updatedb is meant to update the locate database. so you don't have to do that command to get ndiswrapper to show up as a command available to use.

       
    • Anonymous - 2004-09-11

      Ok, this is what I just did :
      1. uninstalled ndiswrapper .9 through Mandrake uninstaller. I rechecked afterwards this uninstaller. No version of ndiswrapper was available.

      2. searched for all "ndiswrapper" file/directory on my hardrive and deleted them but one (no right even as root) :
      [root@localhost /]# locate ndiswrapper
      /sys/class/misc/ndiswrapper
      /sys/class/misc/ndiswrapper/dev

      3. redownloaded the devel/cooker ndiswrapper .9 you provided me with and reinstalled it

      4. reconfigured ndiswrapper with the windows WMP54G drivers provided on CD
      [root@localhost DriversLinksys]# ndiswrapper -i bcmwl5.inf
      Installing bcmwl5
      [root@localhost DriversLinksys]# ndiswrapper -l
      Installed ndis drivers:
      bcmwl5  hardware present
      [root@localhost DriversLinksys]# modprobe ndiswrapper

      Unfortunately, I still have no access to a wlan0 interface.

      [root@localhost DriversLinksys]# ndiswrapper -i bcmwl5.inf
      Installing bcmwl5
      [root@localhost DriversLinksys]# ndiswrapper -l
      Installed ndis drivers:
      bcmwl5  hardware present
      [root@localhost DriversLinksys]# modprobe ndiswrapper

      What shall I do???
      Shall I just reinstall the whole Mandrake? :-(

       
    • Anonymous - 2004-09-11

      Sorry, I forgot to paste this result

      [root@localhost DriversLinksys]# iwconfig
      lo        no wireless extensions.

      eth0      no wireless extensions.

      sit0      no wireless extensions.

       
    • Anonymous - 2004-09-11

      Just tried to uninstall./reinstall ndiswrapper from scratch.
      Still the same result.

      I noticed that the led of the WMP54G card is always off.
      Is it normal?
      Doesn't it mean I have no radio network, which would explain why I can not run iwconfig?

      I am just about to reinstall mandrake once more, while I add so much difficulties making my SB Live work :-(((

       
    • Anonymous - 2004-09-11

      A Mandrake reinstallation from scratch later...

      1st positive point : I can check that I am now able to get my SB Live work quickly ! :-)

      2nd positive point : I managed successfully to install ndiswrapper .10 !
      Here is what I did just after getting my sound card work (I did that first cause I can't stand working without music :-p ) :
      - install the kernel source from Mandrake CD ;
      - remove all files/documents related to ndiswrapper on my drive ;
      - remove the line refering to ndiswrapper in /lib/modules/2.6.3-7mdk/modules.dep ;
      - download ndiswrapper .10 ;
      - install it following the instructions.

      Now here is the result of dmesg :
      ndiswrapper: no version for "struct_module" found: kernel tainted.
      ndiswrapper version 0.10 loaded (preempt=no,smp=no)
      ndiswrapper: using irq 18
      wlan0: ndiswrapper ethernet device 00:0f:66:1b:4e:0e using driver bcmwl5.sys
      ndiswrapper device wlan0 supports WPA with AES/CCMP and TKIP ciphers
      ndiswrapper: driver bcmwl5.sys (Linksys,07/17/2003, 3.30.15.0) added
      wlan0: no IPv6 routers present

      After installing the wireless tools, here is the result I have
      [root@localhost Linksys]# iwconfig
      lo        no wireless extensions.

      eth0      no wireless extensions.

      sit0      no wireless extensions.

      wlan0     IEEE 802.11g  ESSID:off/any
                Mode:Managed  Frequency:2.462GHz  Access Point: 00:00:00:00:00:00
                Bit Rate:54Mb/s   Tx-Power:16 dBm
                RTS thr:2347 B   Fragment thr:2346 B
                Encryption key:off
                Power Management:off
                Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
                Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
                Tx excessive retries:0  Invalid misc:738   Missed beacon:0

      From there, I followed the installation instruction of ndiswrapper and it finally works!!!!!

      The last problem I still have should be quite easy to fix even I have not managed to do so so far.
      When I restard my computer my configuration seems to be lost.
      I just need to type "iwconfig wlan0 key restricted XXXX" to get directly connected to internet.

      My ifcfg-wlan0 file is configured like that :

      DEVICE=wlan0
      BOOTPROTO=static
      IPADDR=192.168.1.100
      NETMASK=255.255.255.0
      NETWORK=192.168.1.0
      BROADCAST=192.168.1.255
      ONBOOT=yes
      MII_NOT_SUPPORTED=yes
      MODE=Managed
      Key=xxxxxx
      ESSID=Rumah

      Isn't it sufficient?
      What shall I add/do to get it configured automatically?

       
    • xNaN0x

      xNaN0x - 2004-09-11

      first off, congratulations :)

      second part, is that in order to configure at boot you need to make/modify an init script but this part I am unsure of on how to do it because i don't use mandrake, I just check it out from time to time. usually these things reside in /etc/rc.d.

      but for sure you are able to get out? I ask becuase your access point shows only 0's.

       
    • Anonymous - 2004-09-11

      Just found the solution : I replaced in file "ifcfg-wlan0"
      Key=XXXXXX
      by
      iwconfig wlan0 key restricted XXXXXXX

      And now, I can leave this Fu#@ng computer and go to my friend's birthday!!!!!!!!!!! :-)

      Thanks once more for all your help and advices!!!!

      Cheers

       
    • Anonymous - 2004-09-11

      It looks like we sent our replies at the same time! :-)

      Yes, the file to be configured in Mandrake is /etc/sysconfig/network-scripts/ifcfg-wlan0.

      The 0's which appear for my AP is due to the fact that when I copied/pasted this, my wlan interface was just up but not connected yet to the router.

      Once more, a big thank you for all your time.
      As I said, I'm new to Linux (even if the Unix training I had a school already a few years ago is coming back little by little ;-) ) and it's really a great pleasure to see this kind of assistance, people taking time to show pedagogy!

      Cheers from Paris!

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks