wah fun - 2010-03-18

I think I have an unusual problem. I could not get Ndiswrapper to work in
ubuntu 9.04 32 bit so I tried the 64 bit version and voila! it works. So, out
of curiosity, I tried ndiswrapper with several other 32 bit distros and it
didn't work with them either. Specifically, even though ndiswrapper would
install the 32 bit drivers and recognize the usb network adapter, it would
never connect to the router. I blacklisted the Staging rt2870 driver that
comes with ubuntu, as well as bw43, bw43legacy and rt2x00usb. (i tried it with
blacklisting these drivers and not blacklisting them.) I can't seem to find
anything on google that specifically addresses this problem.

Here's my setup:
3 GB ram, 2Ghz dual core AMD64 processor
Belkin N150 Enhanced Wireless Router
Belkin N150 Enhanced Wireless USB Network Adapter (F6D4050 and uses the rt2870
driver)
Ubuntu 9.04 32 bit (I also tried 9.10 32 bit with same result)

I am no longer a complete noob but still need help when I run into unusual
problems like this. So, if anyone has an idea, I would appreciate knowing it.

thx