omgwtfbyobbq - 2008-04-15

I've verified that it (netopia swl-2300u) works under winXP and copied the associate inf/sys files, however ndiswrapper -l only listed the driver and not the device, lsusb shows the device as
ID 055d:a230 Samsung Electro-Mechanics Co, and the driver seems to be recognized. After searching the forums, the only idea I could come up with was that the device wasn't recognized because it's PID (A230) is not listed in the inf file. I changed this from B230 to the proper PID, however there's still something wrong/missing according to the output of dmesg

ndiswrapper version 1.52 loaded (smp=yes, preempt=yes)
usb 2-1: reset full speed USB device using uhci_hcd and address 3
ndiswrapper: driver netswl3u (SAMSUNG,12/15/2003,1.1.6) loaded
ndiswrapper (mp_init:216): couldn't initialize device: C000009A
ndiswrapper (pnp_start_device:439): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (mp_halt:259): device eba61480 is not initialized - not halting
ndiswrapper: device eth%d removed
ndiswrapper: probe of 2-1:1.0 failed with error -22
usbcore: registered new interface driver ndiswrapper

I've also tried leaving the inf file untouched and using ndiswrapper -a, but it gives the same result. Are there any ideas as to what I need to do to get this working? Should I install ndiswrapper with debug output?