another Make Error missing gcc

Help
dlennon
2006-03-30
2012-10-06
  • dlennon

    dlennon - 2006-03-30

    Here is my error. I saw someone corrected this with yum gcc, but I can't get to the internet on the linux machine. So How do I fix that>

    [root@localhost ndiswrapper-1.11]# make install KSRC=/usr/src/kernels/2.6.16-1.2080_FC5-i686
    make -C driver install
    make[1]: Entering directory /root/ndiswrapper-1.11/driver' make -C /lib/modules/2.6.16-1.2080_FC5/build SUBDIRS=/root/ndiswrapper-1.11/driver \ DRIVER_VERSION=1.11 /usr/src/kernels/2.6.16-1.2080_FC5-i686/scripts/gcc-version.sh: line 11: gcc: command not found /usr/src/kernels/2.6.16-1.2080_FC5-i686/scripts/gcc-version.sh: line 12: gcc: command not found make[2]: gcc: Command not found make[2]: Entering directory/usr/src/kernels/2.6.16-1.2080_FC5-i686'
    LD /root/ndiswrapper-1.11/driver/built-in.o
    /bin/sh: ar: command not found
    make[3]: [/root/ndiswrapper-1.11/driver/built-in.o] Error 127
    make[2]:
    [module/root/ndiswrapper-1.11/driver] Error 2
    make[2]: Leaving directory /usr/src/kernels/2.6.16-1.2080_FC5-i686' make[1]: *** [default] Error 2 make[1]: Leaving directory/root/ndiswrapper-1.11/driver'
    make: *** [install] Error 2

     
    • Denis Lawlor

      Denis Lawlor - 2008-12-29

      Hi,

      I'm new to Linux and getting same error - missing gcc.

      So how do you install it from yum please ?

      Thanks

      Denis

       
    • sjplnx73

      sjplnx73 - 2007-10-05

      I struggled with the exact same error message until I realised that I didn't have gcc installed. It is normally part of the distribution so can be installed using the same utility - for example YUM in FC3 or YaST in Suse. Once you have gcc installed you shouldn't get those errors.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks