Realtek 8180 (a.k.a. Level One WPC-0101)

Help
2004-03-17
2012-10-06
  • Alain Knaff

    Alain Knaff - 2004-03-17

    I noticed that starting with ndiswrapper 0.6, the realtek driver can be loaded.

    ndiswrapper -i and modprobe ndiswrapper complete cleanly; wlan0 interface appears. If I pick a channel, the Led on the card blinks orange, but unfortunately I cannot make contact with my Access point.

    Here is the output of iwconfig wlan0:

    wlan0     IEEE 802.11b  ESSID:""
              Mode:Auto  Frequency:2.437GHz  Access Point: FF:FF:FF:FF:FF:FF
              Bit Rate:11Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
              RTS thr:2432 B   Fragment thr:2432 B
              Encryption key:off
              Power Management:off
              Link Quality:100/100  Signal level:-95 dBm  Noise level:-256 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

    Note: Many parameters, such as ESSID and txpower cannot be changed (iwconfig returns no error but still shows old values).

    Dmesg shows a lot of messages such as the following:

    wlan0: wireless mode set earlier (1) is not same as wireless mode now (2)

    Any ideas ?

    Thanks,

    Alain

     
    • Pontus Fuchs

      Pontus Fuchs - 2004-03-18

      Realtek is half-working. According to Giri it works with Ad-Hoc mode but not managed mode and you have to use an older driver and not the latest from their homepage. Evil-Bill of "project evil" (like ndiswrapper for freebsd) has the same problem...

       
    • Anonymous - 2004-03-23

      i tried the latest xp driver from realtek homepage yesterday with ndiswrapper in my dsl router (debian woody / kernel 2.4.25). i my card is a pci wlan card form digitus with rtl 8180 chipset.

      i was able to set the essid, the nick, the key and ad-hoc mode.

      when i tried to connect with my laptop to my dsl box crashed (very wierd: it was still routing, i could still login via ssh, but samba stopped working, keventd was <defunct> and no keyboard any more):
      ----------------------------------------------------
      Mar 22 23:28:41 debis kernel: RtlCompareMemory --UNIMPLEMENTED--
      Mar 22 23:28:41 debis kernel: Unable to handle kernel paging request at virtual address f8007024
      Mar 22 23:28:41 debis kernel:  printing eip:
      Mar 22 23:28:41 debis kernel: f89483ca
      Mar 22 23:28:41 debis kernel: *pde = 00000000
      Mar 22 23:28:41 debis kernel: Oops: 0000
      Mar 22 23:28:41 debis kernel: CPU:    0
      Mar 22 23:28:41 debis kernel: EIP:    0010:[ext3:__insmod_ext3_O/lib/modules/2.4.25/kernel/fs/ext3/ext3.o_M4+-400438/96]    Tainted: P
      Mar 22 23:28:41 debis kernel: EFLAGS: 00010082
      Mar 22 23:28:41 debis kernel: eax: f7c627f4   ebx: 00000006   ecx: f7c62808   edx: f7c627e0
      Mar 22 23:28:41 debis kernel: esi: f7fe3d00   edi: f7c6280c   ebp: f7fe3f68   esp: f7fe3d08
      Mar 22 23:28:41 debis kernel: ds: 0018   es: 0018   ss: 0018
      Mar 22 23:28:41 debis kernel: Process keventd (pid: 2, stackpage=f7fe3000)
      Mar 22 23:28:41 debis kernel: Stack: f7fe0001 f8971000 00000000 f7cbfa40 c19dc000 c19dd000 c0304f10 f7ca5740
      Mar 22 23:28:41 debis kernel:        004c4000 c023478f 000000c8 c02347f8 c0198e8a 00000009 0000a000 0000a000
      Mar 22 23:28:41 debis kernel:        c0304d18 c0198fdf c0304f10 c0198d5f c0304f10 c0304f10 000000c8 c0198458
      Mar 22 23:28:41 debis kernel: Call Trace:    [__delay+43/60] [__const_udelay+28/36] [__ide_dma_begin+50/60] [__ide_dma_count+19/24] [__ide_dma_read+231/240]
      Mar 22 23:28:41 debis kernel:   [ide_dma_intr+0/176] [dma_timer_expiry+0/108] [__delay+43/60] [__const_udelay+28/36] [__ide_dma_begin+50/60] [__ide_dma_count+19/24]
      Mar 22 23:28:41 debis kernel:   [__ide_dma_read+231/240] [ide_dma_intr+0/176] [dma_timer_expiry+0/108] [__ide_do_rw_disk+830/1380] [ide_do_rw_disk+49/56] [ext3:__insmod_ext3_O/lib/modules/2.4.25/kernel/fs/ext3/ext3.o_M4+-483148/96]
      Mar 22 23:28:41 debis kernel:   [ide_intr+251/276] [ext3:__insmod_ext3_O/lib/modules/2.4.25/kernel/fs/ext3/ext3.o_M4+-476875/96] [ext3:__insmod_ext3_O/lib/modules/2.4.25/kernel/fs/ext3/ext3.o_M4+-466294/96] [__run_task_queue+80/92] [context_thread+283/416] [arch_kernel_thread+40/56]
      Mar 22 23:28:41 debis kernel:
      Mar 22 23:28:41 debis kernel: Code: 80 be 24 33 02 00 00 75 0d 53 56 e8 44 ae 00 00 8b 9e 64 6d
      ---------------------------------------------------

      is someone out there with an old xp driver from realtek ?

      thanx,

      gnjb

       
    • Pontus Fuchs

      Pontus Fuchs - 2004-03-23

      It crashes because it uses a function that is not implemented yet. I'll implement it later today so please try the latest CVS version tomorrow or so and report back to me at

      pontus dot fuchs at tactel dot se

      or the mailing list. Please include any oops like you did not.

      Pontus

       
      • Mikael Ulfenborg

        It works!

        Just tried with latest CVS and a DWL-610. Drivers from www.dlink.se:  V5.162.1030.2003.zip

        Thought you liked to know..

         
        • Mikael Ulfenborg

          Just an update (forgot the details....)

          DWL-610 _is_ a 8180 based card, I had it working earlier on kernel 2.4.20 with the native driver from Realtek:
          http://www.realtek.com.tw/downloads/downloads1-3.aspx?Keyword=8180

          I also have a DWL-510 (PCI) in my server running Blag-linux (=RH9.0) as an AP with the native driver and it has worked
          perfect for months.

          So, my success with ndiswrapper is on a fresh & updated Mandrake 10.0 with kernel 2.6.3-7mdk
          I'm very happy with this (have been watching ndiswrapper a long time) because who wants to run RH9.0 on a primary laptop ?? :)

           
      • Brian Bockelman

        Brian Bockelman - 2004-03-24

        With the latest CVS version, I got the wrapper to work with the latest Realtek driver (1.66) on a Netgear MA521, and have yet to run into any problems.

        I tried the Netgear MA521 driver, and I got the two following errors consistently:
        "ndiswrapper: Hangcheck returned true.  Resetting!"
        "wlan0: wireless mode set earlier (1) is not same as wireless mode now (2)"

        Hope this is helpful!

         
    • Samuli Järvinen

      Have you had success with ndiswrapper and DWL-510? It has that 8180 chipset but it shows up differently on lspci. If you got it to work I sure would like to know what to hack.. I tried even modifying the inf file but doesn't seem to work. (I'm running kernel 2.6.4 on Fedora Core 1) Well I need to compile ndiswrapper with debugging enabled tomorrow and see if I can figure something out.

       
    • Julien Valroff

      Julien Valroff - 2004-04-17

      I bought a DWL-610 card (based on rtl8180) but cannot get it working. Compiling, loading the driver work both fine, I see a new interface wlan0 when running iwconfig.
      BUT cannot change any parameters (essid, mode, channel etc...) I managed to change to ad-hoc mode once, then I got the link up (but not working as I use an AP).

      If I believ what I see here, it must be possible to ma ke it work, but how???
      I have tried with the drivers from Realtek website, and with d-link drivers, with no success.
      I get the same message as mentionned above, ie:
      "wlan0: wireless mode set earlier (1) is not same as wireless mode now (2)"

      Another problem I get after loading ndiswrapper module is that my keyboard (on a COmpaq armada e500) does not work correctly, I mean, sometimes it just hangs up, then when I type 'i' it enters 'iiiiiiiiiiiiiiiiiiiiiiii' and so on! Is it a known issue? I did not manage to find anaything about his problem!

      Could anybody help me?

      Thanks  a lot in advance ;-)

       
    • Merlin

      Merlin - 2004-04-23

      Everything used to work fine with my realtek card and a cvs checkout of ndiswrapper. But as always I try to keep my system up to date and did an update cvs checkout of ndiswrapper.
      Since then I only get the following messages:
      Starting Realtek 8180 (ndiswrapper)
      Error for wireless request "Set Mode" (8B06) :
          SET failed on device wlan0 ; Invalid argument.
      Error for wireless request "Set Frequency" (8B04) :
          SET failed on device wlan0 ; Invalid argument.
      Error for wireless request "Set ESSID" (8B1A) :
          SET failed on device wlan0 ; Invalid argument.
      Error for wireless request "Set AP Address" (8B14) :
          SET failed on device wlan0 ; Invalid argument.

      I am using the latest driver from the realtek site and the 2.6.6 mm kernel.

      Any help or hints would be really appreciated.

      Thank you

       
    • Jared P. Sutton

      Jared P. Sutton - 2004-04-26

      I downloaded the latest rpms for my fedora kernel (2.4.22-1.2188.nptl), I installed and loaded the realtek drivers for the chipset.  I was only able to get the card to connect to my AP intermittently (even though, it's only about 5 feet away with no obstructions).  These are the best results that I had after working on it for several hours.  But, it's a lot better than some of the people here, so I thought I would post my steps to see if they can help anyone else.  These steps may only work with fedora core, but it might give you an idea of what to do with other distros.

      I'm kind of new working with these things, so if some of my steps seem strange, please forgive me.

      1) install rpms from link on ndiswrapper home page.
      2) ndiswrapper -i NET8180.inf
      3) add "alias wlan0 ndiswrapper" to /etc/modules.conf
      4) cd to /etc/rc5.d/ and change the order of the pcmcia service to start before the network service
      5) modprobe ndiswrapper
      6) start redhat-config-network (soon to be system-config-network in fedora core 2).  Add the wireless device wlan0 and choose your options for SSID and channel, et. al.
      7) Try activating the connection within redhat-config-network (if it doesn't want to active, try rebooting *cringe*)

      After rebooting, I was able to ping my Router, but successive attempts always seem to kill my link.  After a few minutes, the link light came back on and iwconfig showed that I had again connected to the AP.  I opened mozilla, and after a long hostname resolution, I was able to go to both yahoo.com and google.com.  After a few torturous minutes of surfing different pages, I lost the link once again.  So, with my experience, I must say that this is much improvement over not supporting the chipset at all.  But, it still seems a little flakey yet.

      Thanks

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks