junii320 - 2006-06-14

Everything up to modprobe has been done. Whe I first load driver into ndis it says driver loaded, hardware present etc. When I run "modprobe ndiswrapper" nothing happens (no wireless device is created).

This is the output from dmesg after running modprobe...

1.
ndiswrapper version 1.1 loaded (preempt=yes,smp=no)
2.
ndiswrapper (import:238): unknown symbol: ntoskrnl.exe:strrchr
3.
ndiswrapper (import:238): unknown symbol: ntoskrnl.exe:MmFreeContiguousMemorySpecifyCache
4.
ndiswrapper (import:238): unknown symbol: ntoskrnl.exe:MmAllocateContiguousMemorySpecifyCache
5.
ndiswrapper (import:238): unknown symbol: ntoskrnl.exe:MmGetPhysicalAddress
6.
ndiswrapper (load_sys_files:456): unable to prepare driver 'oem6'
7.
ndiswrapper (ndiswrapper_load_driver:92): loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'

Its a dell inspiron 510m with a "Dell mini-pci WLAN card-- broadcom chip) I have tried multiple broadcom drivers from the links page on ndis wiki but none worked. The only one that says "Hardware present" is the one I extracted from the dell installer (Not listed on wiki).

Thanks.. If I can't get it to work, I, at least want to know what the problem might be.