wpa2 only with the -dd option

Help
2010-06-07
2012-10-06
  • joep meloen

    joep meloen - 2010-06-07

    the only way to get my atheros ar5523 and ndiswrapper with wpa2
    working is to use the -dd option from wpa_supplicant
    so when i do:
    wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
    notthing happens, but with the -dd option:
    wpa_supplicant -dd -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
    it runs, how can i fix this ??
    i tried wpa_supplicant ver. 6 and 7
    and kernels 2.6.26, 2.6.27, 2.6.28, 2.6.29 no luck !

     
  • Dirk

    Dirk - 2010-06-11

    Hi penixx,

    some time ago, I had a similar problem with wpa_supplicant. Maybe this problem
    still persists and causes your trouble. You can find a bugfix and information
    about it at http://sourceforge.net/tracker/?func=detail&aid=2686851&group_id=
    93482&atid=604450.
    As a quick test, you could check, if your
    encryption key changes every few seconds after network startup (e.g. with
    iwconfig).
    If this doesn't help, please post a debug wpa_supplicant log (the output of
    wpa_supplicant -dd)

     
  • joep meloen

    joep meloen - 2010-06-12

    problem solved i used the patch from schwende :

    diff --git a/src/rsn_supp/wpa.c b/src/rsn_supp/wpa.c
    index b221476..d7a7510 100644
    --- a/src/rsn_supp/wpa.c
    +++ b/src/rsn_supp/wpa.c
    @@ -994,6 +994,8 @@ static void wpa_supplicant_process_3_of_4(struct
    wpa_sm *sm,
    NULL, 0, &sm->ptk))
    return;

    • sleep(1);
    • /* SNonce was successfully used in msg 3/4, so mark it to be renewed
    • for the next 4-Way Handshake. If msg 3 is received again, the old
    • SNonce will still be used to avoid changing PTK. */
     

Log in to post a comment.