possible bug in nco-4.0.6

Developers
2011-01-24
2013-10-17
  • Davide DelVento (was javacorner)

    Downloaded tarball and tried to install it on bluefire. Failed with

    "nco_pck.c", line 866.36: 1506-046 (S) Syntax error

    Following patch fixed it (maybe already in newer versions, I'm reporting since it might affect only our architecture)

    -- install/nco/nco-4.0.6/src/nco/nco.h.original  2011-01-24 14:55:42.000000000 -0700
    +++ install/nco/nco-4.0.6/src/nco/nco.h   2011-01-24 14:55:51.000000000 -0700
    @@ -227,9 +227,6 @@
       /* NCO began using MIN/MAX tokens in nco_pck.c on 20101130
          Not sure when these tokens were introduced to netcdf.h */
    #ifndef NC_MAX_BYTE
    -# define NC_MAX_BYTE
    -#endif
    -#ifndef NC_MAX_BYTE
    # define NC_MAX_BYTE 127
    #endif
    #ifndef NC_MIN_BYTE

     
  • Charlie Zender

    Charlie Zender - 2011-02-02

    thanks for the report. you are the second to find this. i don't know why it compiles on most platforms with this bug.
    as usual, xlc has the most stringent checks.
    it's fixed in cvs. hoping to get one more patch in before releasing this in 4.0.7.
    thx,
    cz

     

Log in to post a comment.