nco 4.0.5 and --enable-mpi

Developers
Anonymous
2010-10-19
2013-10-17
  • Anonymous - 2010-10-19

    I'm trying to build nco with MPI support, but am getting a compiler error:

    mpncbo.c: In function ‘main’:
    mpncbo.c:613: error: ‘lmt_all_lst’ undeclared (first use in this function)
    mpncbo.c:613: error: (Each undeclared identifier is reported only once
    mpncbo.c:613: error: for each function it appears in.)
    mpncbo.c:613: error: ‘nbr_dmn_fl’ undeclared (first use in this function)

    I'm configuring with nothing fancy: just -enable-mpi

     
  • Charlie Zender

    Charlie Zender - 2010-10-20

    Hello,

    Err, umm, -enable-mpi is not currently supported. It used to be and will be again.
    But it has been broken for some time due to non-maintenace.
    Thanks for reminding me that this option should be removed until it works again.
    Will do that in 4.0.6.
    cz

     
  • Anonymous - 2010-10-20

    ok, thanks.   if i want to go back in time to try it out, what version should I use?

     
  • Charlie Zender

    Charlie Zender - 2010-10-20

    3.2.0 is a good choice.

    cz

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks