#42 Crash on export PDF

closed-fixed
Plugin (17)
5
2012-03-23
2010-11-14
Anonymous
No

Hallo,
Programm crashed on exporting pdf, when previously exported pdf is already open by another program an thats why not writeable. See crashlog.

Thanks.

Discussion

  • Nobody/Anonymous

    Crashlog from exporting pdf

     
  • Malte Ried

    Malte Ried - 2010-11-17

    Hi!

    Thanks for reporting this bug. NClass really should not crash if the PDF file is opened by another process. I fixed the code in SVN so it will be part of the next release. If you don't want to use the SVN version of NClass, there is a simple workaround, of course: Close the PDF file at the other application before exporting ;)

    Malte

     
  • Malte Ried

    Malte Ried - 2010-11-17
    • status: open --> closed-fixed
     
  • fj0823

    fj0823 - 2011-03-24

    An error occurred to loading PDFExport.dll on start up, and launched. (using winXP, NCLass v2.03).
    And resolved by moving "./bin/plugins/PDFExport.dll" to "./bin/PDFExport".
    To the report above.

     
  • fj0823

    fj0823 - 2011-03-24
    • status: closed-fixed --> open-fixed
     
  • Malte Ried

    Malte Ried - 2011-03-24

    Hi!

    Two questions to clarify:
    - Did you use the installer or the compressed binaries?
    - You moved "./bin/plugins/PDFExport.dll" to "./bin/PDFExport.dll"?

    Malte

     
  • fj0823

    fj0823 - 2011-03-24

    Hi! Thank you for quick response.
    And I'm sorry for my broken English.

    - I tried both.
    - yes (to trouble shoot)

    A message was shown in dialogue:
    There was an error while loading the plugins:
    PDFExport, Version=1.0.0.0, Culture=neutral, PublickKeyToken=null

    Best regards,

     
  • Malte Ried

    Malte Ried - 2011-03-24

    Hi again!

    That's really strange. I wasn't able to reproduce this bug until now, so I need more input :)
    - Which is your (Windows) locale?
    - Could you send me a screenshot of the error message since it should display some more information than you wrote?
    - Which .NET framework is available on your machine?
    - After moving the PDFExport.dll to the bin directory: Do you see the menu entry "Plugins/Export as PDF..." (or so)?

    I hope to find out whats going wrong there with these informations.

    Malte

     
  • Malte Ried

    Malte Ried - 2012-03-23
    • status: open-fixed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks